Download

GlobalShaderCache-PC3D_SM5.bin is missing

I would like to compile a project in Debug Game Mode and I have got an error:

"
The global shader cache file
‘G:/ProgramFiles/…/Engine/GlobalShaderCache=PCD3D_SM5.bin’ is
missing.

You’re running a version of the application bluilt to load COOKED content only,
however no COOKED content was found. Consider cooking content for this build,
or build and run the UNCOOKED version of the application instead.
"

What I have to do? Thanks

I have the same problem

There are a number of build configurations available to you, but it helps to think of them as two parts, a “State” and a “Target”. In this case, your “State” is DebugGame. There are two “Targets” you could have, one that is blank, so the total build configuration is listed as “DebugGame”, and one that is for opening in the editor, so the total build configuration is listed as “DebugGame Editor”. The blank target is actually looking for cooked content, and so that probably explains the error message. Are you able to build in “DebugGame Editor” and then open the project from within Visual Studio (with Debug > Start New Instance)?

Nice trap. :wink:
Had the same problem on OSX when running a game , following the “Pizza” example.

CGImageSourceCreateWithData data parameter is nil
LogMaterial:Error: The global shader cache file ‘/Users/frank/dev/git/Unreal/4.1/UnrealEngine/Engine/GlobalShaderCache-GLSL_150_MAC.bin’ is missing.

You’re running a version of the application built to load COOKED content only, however no COOKED content was found. Consider cooking content for this build, or build and run the UNCOOKED version of the application instead.

Changing the target to “PizzaEditor - Mac” helped.

Same problem here

I’m facing the same problem and can’t figure it out

I tried all possible package options, but always i get the error that this bin is missing

Running on mac 10.10 and UE 4.8.1

Can someone tell me how to get this fixed?

I have done more research over the weekend and tried every possible combination, within the package settings. But every time i’m getting this error that cooked content is missing
Obviously i hit the COOK FOR MAC button, So i really don’t understand whats wrong here.
Could this be a bug?

I have same problem with my blueprint project, when packing for MAC.
Can’t Launch app on MAC too … same project works fine on Windows. No fix yet ?

Edit: Same app was working fine on my MAC, packed with 4.6 and 4.7, but not working with 4.8.

I have the same problem.

"The global shader cache file /Contents/UE4/Engine/GlobalShaderCache-GLSL_150ES2.bin is missing.

You’re running a version of the application built to load COOKED content only, however no COOKED content was found. Consider cooking content for this build, or build and run the UNCOOKED version of the application instead."

Tried to change the target like rotwang suggested, couldn’t find that option though… oO Help?

@Lauren Ridge:
Ok, this is an old thread, but this means “DebugGameEditor” is the only working configuration until the game is finished and only testing remains?

I continue to have this issue. Any word on a fix?

I’m very new to all this, but from what I’ve read, it seems that any build target prefix xxx with editor should be wanting uncooked content. However right now, at least on my machine at 4.9.1 only development editor wants uncooked.

I haven’t had any luck with the -game command line parameter either. I’d really like both engine and game in debug with uncooked.

I am also getting this issue on all the Solution Configurations including “DebugGame Editor” and “Development Editor” in the sln provided by the 4.9.2 download.

However I can get around this issue by switching my project to a source version (github) by: right click on the *.uproject file > Switch Unreal Engine version… > Choose the location where I keep the full source.

The reason I was using the downloaded version was so I can have a stable base for using the engine, instead of working on the engine. Also the git dependencies use tons of GB of my bandwidth and Comcast is reportedly putting up data caps now. And double that for using UE4 on my Mac and on my PC.

However we can’t use the downloaded version to do debugging with Visual Studio tools, for example, setting a breakpoint and stepping through the code, because of this issue. It is still possible to do printf debugging, and blueprint breakpoints with the binary download though, so maybe that’s why many people are not complaining about this.

It would be nice if someone smarter than me could solve this.

Any fix for this?

Hello,

I am having the same problem. Building the game in DebugGame mode causes Xcode to complain on launch, about missing cache for cooked data. Building for DebugGame Editor mode gets Xcode to launch the UE4 editor, from where I can launch the game. But the UE_LOG messages I have sprinkled in my code still don’t show up in the output log. My problem - how do I debug? Would very much appreciate help from seasoned developers on alternate ways to debug code.

Vijay

I am having the same problem. Help me :frowning:

Hello Guys, I had a same problem. I am running UE4 4.11.2
15d9a7de05bb3fdd49007f598a92bb1721128570.jpeg
It was caused by running game from network location. Once I have maped any network location as maped drive, it was OK also.
Once I have copied WindowsNoEditor folder to local machine, problem disapeared…
Doesnt matter if it was development 32bit, or shipping 64bit.
See my packaging settings, all runs perfect from local machine.

dev 32bit
1a49c0339bfa404a039efde53e8a25914bfb253d.jpeg

shipping 32bit for distribution

shipping 64bit for distribution pak files

All this packaging profiles works from local machine or from maped network location.

I am using Unreal Engine 10.4.4 and am having the same problem. The global shader cache file ‘/Users/Admin/Downloads/MacNoEditor/ScatterBrain.app/Contents/UE4/Engine/GlobalShaderCache-GLSL_150_ES2.bin’ is missing.
Your application is built to load COOKED content. No
COOKED content was found; This usually means you did
not cook content for this build.
It also may indicate missing cooked data for a shader
platform(e.g., OpenGL under Windows): Make sure your
platform’s packaging settings include this Targeted RHI.
Alternatively build and run the UNCOOKED version
instead. It works on my Mac I cooked the content before packaging but apparently a file is missing and this is a known issue. When I put a sharable link for example http://mega.nz/#!dt4nDDRT!NQZ6iq2JBKnYV3SYqxGTc-iUC38iLFnmA-ysfJ6iNb8 and someone tries to download and open it, it won’t work they get said error or it says can not open page.

!NQZ6lq2JBKnYV3SYqxGTc-iUC38iLFnmA-ysfJ6iNb8 is the decryption key part of the link

Also, you can’t run the build off a network drive. Just dropping this info here. Mapping the drive works.

how can run it again:
1.*_Editor Mode Can,but Game mode is still disable run without a crash
2.run the *.uproject,just cook it.

Why a big ue4 game run well?Because ue4 pre Cook content(lighting?) in editor Mode.
When we got a game,it must have cooked contents.