Download

glitch

hey
so i got this strange glitch :

its perfectly fine in model preview:

what the heck is going on?

That is Z-fighting, where a polygon is in the same location as another polygon and it doesn’t know which to display–make sure you didn’t place the same mesh twice.

why is it looking fine in the preview then?

It’s Z-fighting, somewhere you have duplicate polygons, whether you placed two meshes there or it’s actually there in the static mesh but not visible in the preview it’s somewhere.

so how do you get rid of this without changing the geometry?

you need to delete the duplicate polygons–however they got there they aren’t necessary.

they are necessary, trust me, this way i can model faster. So you dont know why is it looking ok in the preview? there has to be something you can turn on/off

What he means is, that there is probably another model in your level (or the same) and unreal doesn’t know which to display, this is usually described as Z-Fighting - You can learn more about this here: Z-fighting - Wikipedia
Make sure this is not the case, if it is I have no idea what it could be.

I know what he meant and what is z-fighting, im just curious why this is not happening in other 3D apps, this сrap only appears in UE4 main editor window…soooo any solutions on how to get rid of this?

so…no one knows how to get rid of this?

I told you several times the issue, you have to find the duplicate faces or meshes and remove them, there’s no other option, you can’t have polygons occupying the same space.

Yes, but you didnt tell me why its not happening in the preview…

i read this thread in 30 sec. It’s pretty clear: in preview you don’t have duplicate, in your level you do.

funny you should say that, because its the same asset…

so you refuse to resolve it because you want speed > quality? looks like the outcome is exactly what you want then.

I dont want this outcome,and thats why im asking for help…

fixed it, thank you people