Download

GI and precomputed shadows issue

Hello UE community!

I am having weird issue with shadows for foliage models on terrain, using classic way of level compilation I got strange shadows result, lightmaps look awful. I’ve tried to raise lmaps resolution up to 1024 for mode, also for terrain… that didn’t help, what am I doing wrong? Also I tried GI way, I know it is in raw stage at the moment, however maybe it would work, but shadows looks strange, instead of leaves and branches, my shadow is completely black.

This is precomputed:

http://postimg.org/image/rbznpzkff/

This is GI light model enabled:

http://postimg.org/image/dxtwjjxjt/

Thank you for any help!
With all respect
Wozner

You’re using the wrong settings–the setting you changed was for the lightmap packing, which is where it takes lightmaps and packs them into larger textures so instead of like say 50 lightmaps it combines them into like 20, that setting you set to 1024 just configures how big of an image to pack them into.

To increase the resolution of the lightmap you have to select the object that is receiving the shadows, if it’s BSP then just click on it and go into the object properties and lower the lightmap resolution value (which increases the resolution for BSP).
If it’s a Static Mesh, you can open the static mesh from the Content Browser and set the default lightmap resolution for that object there.

In your second image your directional light is set to Movable, which means it only casts dynamic shadows without GI, you need to set it to either Stationary, or Static.

Thank you for the answer, I tried that way but no luck. I have reached model editor, and raised lightmap resolution up to 512, that did not change anything. Also clicked on landscape and decreased its resolution to 0.5, still the same. I found, I was missing light importance volume, so I did one, and set it 1000x1000, but unfortunately it is still like I showed on my screens. By the way, is there any way to mark specific area, which I want to build with lighting? So with that I will save some build time, because building whole level takes about 10-20 minutes, which is painful for me.

Hi Wozner, the issues with shadow you expieriencing, are caused by the way lightmaps are stored i found that increasing lightmap resolution to be only partial fix especially when shadows are casted by jagged masked materials/objects (trees) increasing lightmaps resolution is pointless in situations when you dealing with bigger levels. Personally what i end up eventually doing is selecting directional light and making it cast real time cascaded shadows in close proximity to player. Remember to keep light stationary when doing this all you need do to is finding value in light properties witch will specify dynamic shadow radius around your player, look for “dynamic shadow radius” or something similar i use it all the time but cant remember the name, you will also be able to specify number of shadow frustums and multiple settings that define the way in witch realtime shadows blend with precomputed shadowmaps at distance.