Download

Getting Phantom Hits in Air Hockey Game. Anyone know what could be causing?

Hi everyone! I’m working on an Air Hockey game and all progress has been stopped because I’m getting these strange random phantom hits and movements from the puck. If anyone knows the fix for this, please let me know. I’ve been stuck on it for a few days so would really appreciate any help. Thank you! Here is a video that shows the issue in question:

       [https://www.youtube.com/watch?v=IK9l_W6Wz2A](https://www.youtube.com/watch?v=IK9l_W6Wz2A)

Thank you so much for any help!

Not sure why the link came up like that. Here is the link:

Thank you so much for any help! Been stuck for a week on this. Super frustrating

If you put four or more space bars before the text, the text will be preformated for code.


You could try pressing ALT+C to show collision, or set the view mode to “Player Collision”

PlayerCollision

That may help you find any strange collision in your scene that is causing the random hits.

Hi NachoMonkey2, thank you for your help! Is there a way to enable this while in Play mode? When I play it goes back to Lit mode. When I check Player Collision there is nothing there. I think it is a setting with the Physics Engine or the Collision just generating random false phantom hits. Here is a screenshot of what shows when I check Player Collision, but I can only get it to show when it isn’t in play mode

I also tried just removing all collision for the table surface, so it should behave as if it doesn’t exist, but there are still random phantom hits generated

Pressing F8 will eject you from the game while it’s playing, and the view mode will switch back to “Player Collision”.

Hi NachoMonkey2! Thank you, with this it can be verified, there is absolutely nothing that could be causing the collision. It’s just completely phantom and I just need to figure out what would be generating false and random collisions. If you have any ideas about what physics or collision setting would be generating false collisions, that would be awesome. Thank you for your help!

It appears to have been due to the Physics Material that I had on the puck. I had the density set to 0 because I wanted it to be as light and fast as possible. Setting it to 1.0 seems to have fixed it. Thank you NachoMonkey2 so much for all the help! And thanks to Everynone in the Answerhub who suggested it could be the physics material

1 Like

Glad I could help!

1 Like