Download

Getting an animation to actually play (SOLVED)

Ok i have the animation sequence made. I use play from the mesh to get it to play but nothing. What else is needed to actually get the animation to play. If anyone knows how this works , a few tips would be great.

I don’t know about an animation sequence, but never once have I ever said “let me put it in the mesh”. As much as i would like it, using animations inside the character BP is complete trash, and you can only play montages in pretty sure. Do some Anim BP tutorials. No idea if you’ll understand it at first, but you will in like three hours. If you don’t want to, just do the following for it:

  1. Make a variable for is doing whatever tf you want it to do
  2. On begin play in anim BP cast to character and promote to a variable
  3. Make a state machine (you can look that up)
  4. Do the arrow stuff and get your reference node, pull out the variable you made at step 1, plug it into result, and you’re done. Remember to do it the other way around with a not condition or something
  5. Apply the anim BP to the mesh in the BP editor.
1 Like

Hey thanks for the info, i am digging into that right now. I have done a lot of animations in UDK. this is very very much the same, just a bit different.

Animation Blueprint is the closest analogue to AnimTree in UDK. I am struggling mightily with this myself right now, as I’ve recently returned to the engine from a decade break, and the Anim Blueprint concept is a billion times more complex (ok, maybe that’s an exaggeration, but holy hell is it a lot more complex) than Unreal 3’s AnimTree was.

@eblade man is it i’m with you here. I made an animation in the modeler could not get it to work So i made one in the editor in the sequencer, once i fIgured it out. I have 2 animation one of each, both play good when testing them, but in game i cant get it to run.

What i am after is just a pull on a handle. A simple animation on one model. when you activate it, it pulls the handle, that is it. Nothing super special.

Just can not get it to run when i need it to. I went into he properties of the model, told it use this animation. Then tried to tell the mesh->play() but that did not work.

If you figure this out let me know, i will do the same. Been at it most the day and still have not solved this.
Running out of ideas. I am trying this in montage not in blueprint.

I got it to finally play, but only the 1st time after the 1st time it will not reactivate. I found that in my properties where you set it to be a blueprint or an asset. I set mine to an asset and unchecked play then in code i use the below code to get it to play, but it only plays the 1st time not after the 1st time. Trying to solve that now.
this->GetMesh()->Play(false);

For your purposes, you probably can just get away with looking up a tutorial text or video on how to make some basic animation blueprints.

I, unfortunately :smiley: have recently joined an already existing commercial product, and it’s ABPs are absolutely insanely complex compared to anything I’m used to seeing in Blueprint.

I figured it out. When you set the properties in the model window in editor you must uncheck the play check box then when you run play it will play and to get it to replay you must set the track start point to 0.0f every time, that is it and it works great. Figured it read the tracks start point from the default properties window, only the 1st time. After that you must set them, then it wiil replay that animation.

So in short, uncheck play in properties window and set the track starting position every time to 0.0f before you call play. It will work perfect every time then.