Download

Generic Gamepads

Hi!

So I have a generic usb gamepad, one of the Gameware gamepads, and I want to use it in my proyect. But I’ve been trying for a while, and unreal 4 doesn’t seems to get it.

The gamepad works in games, so is an unreal 4 problem.

I’ve been reading about, unreal 4 doesn’t support generic controllers, so I wanted to ask, if anybody had tried before, and if there is a solution to the problem.

Maybe using 360xce or Vjoy, but I didn’t get any luck with that.

Or is unreal planning to add support to this controllers in the future?

Thanks very much

Any solution about it? I have a generic USB gamepad, but UE4 dont react to it…

UE4 works with any controller that uses XInput. After that, you need to make sure you have your input actions/axis set up to also accept controller input:

https://docs.unrealengine.com/latest/INT/Gameplay/HowTo/SetUpInput/Blueprints/index.html

Let me know if that helps

So, no generic controller support…

You could use an xinput emulator for your controller.

I am not sure if this would help, but if you are trying to avoid XBox and PS3/4 controllers specifically, then we also do testing with Logitech Gamepad F310s and it works perfectly fine.

Hey, I know, 1 year later, anyways, I think what he meant is using DirectInput controllers. Personally I am trying to get a joystick controller that uses DirectInput with UE4. The plugins I found on forums are by Ikarus76 and getnamo. But they don’t support 4.8 and my project is well off in 4.8 to start all over.

Links to the forums regarding this

USB Joystick - C++ Gameplay Programming - Unreal Engine Forums - who never posted a link to his workaround :3 and I couldnt find it and x360e is no good since you need to package your game to test every time.
Joystick Plugin - Engine Source & GitHub - Unreal Engine Forums

Hi 2 years after, I dont know if you solve the problem, I search about the same problem, I have a generic controller and I activate the WINDOWS RAWINPUT PLUGIN in plugin section of unreal and the input select list show GenericISBController list, and my controller works. I hope this help.

Cheers

I have tried this stuff out.

I do know how to configure, but the issue is my player keeps moving in x without me giving any controller input.

Does some one know a fix?