[Gear VR 4.14 and 4.15] Vulkan Black Screen or Crash on Initialial Game Load

I’m using a Galaxy S7 (not Edge) running Nougat, and when I try to load any game using ES3.1 or Vulkan, I get either a black screen with no audio, or the game just crashes. I have attached a combined logcat containing both scenarios. I’ve been at this for weeks, Googling the topic to death, and trying every combination of project/editor settings I think are even remotely relevant, and I still got nothing. While I experience the problem on both 4.14 and 4.15, for this particular instance, I decided to uninstall 4.15 completely, reinstall it fresh (binary, via Epic Launcher on Windows 10, if it matters), and used an unmodified First Person Shooter Template project.

If you need me to, I can upload the entire project, but it’s simple enough to recreate, I doubt you’d need it. It’s a standard Blueprints project. Thanks for your time.link text

After weeks of trying to make this work, I finally stumbled across the answer. It turns out Oculus is working with Khronos Group (the guys who make Vulkan) to get it working on the Gear VR, and it’s still not done yet, with no ETA.

The problem is, according to Oculus:

Unfortunately, Vulkan on mobile still doesn’t support front buffer or multiple queue rendering. We are working with Khronos to wire these up, but there isn’t an ETA yet. My hope is that they will land in the next 3-6 months, but we can’t promise that with any certainty.

That was back in Nov 2016, and we still don’t have an ETA yet. So for anyone else Googling this topic, there’s your answer. Vulkan doesn’t support it yet.

Source: Oculus Community - Oculus Community