game mode changes look?

Hi all,

I am trying to figure out why this is happening. I have never had this happen to me before.

When I toggle on game mode ( hit the g key ) it shows the results of my post process volume settings. So it turns them on and off. I have never had that happen before. Is that normal?

Issue is I want to take screen grabs showing my ppvolume settings but it shows the lights and reflection spheres as well as camera in the scene.

What did I do wrong?



The G key toggles Game view which means it shows/hides all icons, volumes, gizmo etc on the scene, nothing abnormal here :wink:

I understand that, and I agree with you. But my issue is the g key actual turns on and off my settings. Notice how the 2 images are different looks?

Hum, the difference is too subbtle for me, but sometimes ago in my project I had an actor that I set to invisible in the world outliner, and its visibility was toggled with G. I’ve tried to reproduce this behavior but without success so I’ve supposed it was a bug.
I’ve just tried with a PP and no way to have your issue

Can you “Reset Viewport” in the Viewport > Show option? The bottom screenshot looks like a scene-referred linear image, which may be from the tonemapper being disabled in the Post-Process section of the Show tab. AFAIK, the Post-Post Process volume can’t be toggled, so it’s something with the viewport since it has two modes that can store separate settings between game and editor mode, as you’re seeing.

Not sure what I did exactly but its totally fine now. I think I hit the “default” in the Show bye accident. Now it works fine.

Thanks for the help.