Game crash while loading level


We are building a VR game for HTC and the game randomly crash just after a level load (a first frame of the level is rendered in the headset). Here is [logs and various files][1].

Thanks !

Hello gobanos,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any settings/blueprints that may be involved with this issue?
  4. Could you provide your complete callstack that is given via the crash reporter?


I tried to reproduce this with VR startup content, but I can’t.
The crash reporter won’t launch, I just got the “classic” crash window.

On my dev computer I manage to launch the debugger, so I have a (little) more detailed error :


But without the symbols, it’s meaningless…

I join a screen where you can see the stack :

And a other with the method to open a new level :

Thanks for your time !

I ran more tests on our end with the information provided. However, I have not been able to reproduce this issue on our end. Could you provide a stripped down copy of the project so that I could take a closer look?

Hello gobanos,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.


Hello Rudy,

I managed to get a few more info, seems to be the assert “check(IsInRenderingThread());” in Engine/Source/Runtime/MediaAssets/Private/Misc/MediaTextureResource.cpp:564 who fail.

I have a dump and a pdb file, but they are quite heavy (2.6Go and 83Mo respectively), is there a way to send them to you ?

Thanks !

Could you provide the project via google drive or drop box so that I can take a closer look?
I can’t send you more than that, I hope that would be enough.

IMO the assert who fail is in FMediaTextureResource::ConvertResource(struct FMediaTextureResource::FResource const &) stack, address 0x00007FF6344BD70B: call IsInRenderingThread.

Thanks !

I have been unable to reproduce this issue with the information provided. Could you check to see if this issue still occurs in the 4.16 preview?

Thanks Rudy,

I couldn’t reproduce this issue with 4.16 preview, is release date already planned ?

We do not have a release date at this time for the 4.16 release. I am happy to hear that the issue is no longer occurring the latest version. If the issue returns for the latest version feel free to reopen this issue with a reply containing any additional information you may have and I will be happy to investigate further.

Make it a great day