Game cashing when downloaded from PlayStore


I recently uploaded my game on the PlayStore and I face a weird issue. When I install my game via USB using the BAT install script all works fine but when I install it from the PlayStore, I see the splashcreen and the game crashes with this error report:

*** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
Build fingerprint: 'asus/WW_Phone/ASUS_X007D:6.0.1/MMB29M/'
Revision: '0'
ABI: 'arm'
pid: 7989, tid: 8004, name: Thread-910  >>> com.linkpulsion.RollTheBall <<<
signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x0
    r0 00000000  r1 dd07cf08  r2 00004001  r3 00000001
    r4 e205bb44  r5 eb92e3c0  r6 e205bb3c  r7 dd07cf08
    r8 00000001  r9 dd187780  sl 0000003f  fp dd07cf00
    ip 00001f44  sp dd07cc08  lr dec536d4  pc dec53c48  cpsr 400d0010

    #00 pc 015b6c48  /data/app/com.linkpulsion.RollTheBall-1/lib/arm/ (_ZN13FZipUnionFile12AddPatchFileE10TSharedPtrI18FFileHandleAndroidL7ESPMode0EE+32)
    #01 pc 015b66d0  /data/app/com.linkpulsion.RollTheBall-1/lib/arm/ (_ZN20FAndroidPlatformFile8MountOBBEPKw+100)
    #02 pc 015b5494  /data/app/com.linkpulsion.RollTheBall-1/lib/arm/ (_ZN20FAndroidPlatformFile10InitializeEP13IPlatformFilePKw+1452)
    #03 pc 01572b14  /data/app/com.linkpulsion.RollTheBall-1/lib/arm/ (_Z11AndroidMainP11android_app+2708)
    #04 pc 0157638c  /data/app/com.linkpulsion.RollTheBall-1/lib/arm/ (android_main+120)
    #05 pc 0158a018  /data/app/com.linkpulsion.RollTheBall-1/lib/arm/
    #06 pc 00041823  /system/lib/ (_ZL15__pthread_startPv+30)
    #07 pc 00019285  /system/lib/ (__start_thread+6)

For information: I uploaded both APK and OBB, the OBB verification on first start/update is disabled.


The pasted log does not tell anything. Just a signal 11 error…
We need the full log to see what is going on… Try to log with adb logcat…

It looks like you hit an error in AddPatchFile() in AndroidFile.cpp. I’m guessing the OBB file is missing or corrupt.

I tried to rebuild the whole projet then recooked for Android and reuploaded it on the PlayStore, the game keeps crashing… It occurs on all the devices I tried with.

I checked the downloaded OBB with my file manager and the file seems legit (write size etc…).

**EDIT 2

**I openned an issue on the answerhub : Game crashing when downloaded from PlayStore - Mobile - Unreal Engine Forums