Download

FPS template glitching with terrain

I found some odd behavior while testing the FPS C++ template with some basic low poly terrain. What happens is the arms and gun completely disappear after colliding certain ways, and the player can no longer move the character or change looking position. I’ve uploaded a small demo video (webm, 7mb) to dropbox you can view here: https://www.dropbox.com/s/bv1giwbsmk0n1m4/fpsterrainglitch.webm?dl=1 (direct download because dropbox’s preview doesn’t work. If it saves as a file in your browser, you can drag the file into your browser to play it without a media player installed on your pc)

GIF preview:

https://dl.dropboxusercontent.com/u/1215621/fpsterrainglitch.gif

In the video you can see this happens in two close, but unique locations and jumping around I can get it to happen in a couple more places.

Is this a bug with the controller? Or is this some odd expected behavior? I’m using 4.6.1 for reference. Completely unmodified code, blueprints, etc.

Hi minderaser,

It looks like your player has hit a killz and it subsequently destroyed the player pawn. Make sure you don’t have anything in that area that is acting as a killbox or killz, or otherwise destroys actors. Additionally check to make sure you can use console commands after the character is destroyed, specifically try ~restartlevel. If this works then something either in the code or around that area in your video is simply destroying the pawn.

I had an issue with this in the past (blueprint based project) as well, the problem turned out to be the Kill-Z setting was too high, so as you are going lower down the terrain you eventually trigger the Kill-Z.

Go to the Settings button on the toolbar and open World Settings, from there you can lower the Kill-Z down further so it’s below your landscape. Also check to make sure your landscape is positioned correctly on the z axis, if you sculpted the landscape lower you may need to raise it up.

If that still doesn’t work I have seen this resolved by turning off “Enable World Bound Checks” from the World Settings panel, but this a bit of a brute force approach and may cause other issues. :slight_smile:

Thanks to both of you, kill z was indeed the problem! (I had no idea such a setting even existed)