Download

Forward Rendering - Disabled All light shadows still getting overlap error why?

Hi,

I have read about the 4 shadow casting - light overlap limit while using forward rendering. However In my scene none of my movable point lights are casting shadows yet it still gives me an overlap error and writes that it is “Disabling shadows”. I have something like 4 or 5 lights some of them not active all the time.

What gives?

Also is there any way in the project settings I can entirely disable all shadow casting from the engine and movable lights?

Sky light and directional lights count.

Don’t have any of those in the scene. In fact right now I have only two lights in the scene (both moving) one spot light and one larger point light, both have shadows turned off. They get activated via a BP on a moving Asset, and every time the point light does i get an overlapping error Shadow casting Disabled message.

Hey William, did you manage to fix this? Running into the same thing.

No, I didn’t. I am hoping someone can step in to clarify this error message, it seems to be doing no harm but one can never know.

Same error here.

I can understand why there is an error since my light are not in stationnary but movable?