Download

Feet hitch in play, but not in blendspace sample play. Only backward move, not other directions.

Hello, my feet seem to do some sorta weird flip floppy fish out of water looking type of anim when I walk backwards.
This does not happen at all in the blendspace sample.
I tried setting the input interpolation to all various options, and BSA or none seem to be the best result.
Also, in the Sample Interpolation, Target Weight Interpolation at 1.0 to 2.0 seem to be the best to, anything out of that range just increases the rate of this floopy feet.

But most times, after hitting play, the feet can move about 4-6 loops of the anim before they start hitching up.
This only happens with the backwards anim.
I have 4 backward anims, standing walk, standing run, crouching walk, and standing aim.

Like i said ALL work fine in the preview graph of the blendspace, or in the preview of the anim blueprint. But not when playing.

Anyone have any ideas?
anim in blendspace.

anim in play

I just noticed, this same thing happens with the anim starter kit backwards to on the ue4 mannequin, so it has to be the character controller right?
I did some print strings with the direction variable in the anim blueprint graph, when holding backwards, its not constant -180 but blinks into positive for mili seconds. Same with the forward value.
But doing this with the axis value on the character input in the character graph, shows a solid -1 or +1

Even if this is the case, it still doesn’t make sense that all the forward and side anims look just fine.

after some more testing, I determined its caused from the get forward vector,
switching the anims in the blend space so forward was using backstep and backward was using forward step, it was the forward anim all messed up when they forward vector was being told to use the opposite value, but then the back step anim was perfect.

un hooking the get forward from the -1 axis and using other methods, i found out that was surely the cause, but cant find a way to use inPlace anim for going backwards without using the getforward within the code that determines what is backward.
ugh, so annoying.

Thanks.