Download

Feedback on the new docs site

Hey guys, the code formatting seems whack on these macros: Multi-cast Delegates | Unreal Engine Documentation

Exporting a cubemap with NVIDIA’s Photoshop tool has changed quite a bit, might be worth updating this article, the interface is much different now. Exporting Cubemaps | Unreal Engine Documentation

Hi,

I don’t know any other right place where I have to note and I’m newcomer in Unreal engine and If I’m wrong just ignore my post. :slight_smile:

It seems like, on the documentation Player-Controlled Cameras | Unreal Engine Documentation in the First step code isn’t working. We need to add the next lines code:



#include "Camera/CameraComponent.h"
#include "GameFramework/SpringArmComponent.h"


It should look like below:



#pragma once

#include "CoreMinimal.h"
#include "GameFramework/Pawn.h"
#include "Camera/CameraComponent.h"
#include "GameFramework/SpringArmComponent.h"
#include "PawnWithCamera.generated.h"

UCLASS()
class FPSPROJECT_API APawnWithCamera : public APawn
{


Please, fix the documentation.

Thank you.

https://docs.unrealengine.com/en-US/Basics/UI/LevelEditor/Viewports/ViewModes/index.html
This link only takes you to an table of contents page and has nothing to do with ViewModes as described. I’ve also had this happen with other links of this type. Getting answers from the unreal site is very difficult.

The image is no longer displayed. Instead I see this text boxed in red:

An example hardware layout with three render nodes(h:600)](incameravfxdiagram.jpg)

Thank you

Hey Echo_Four, I could have been more specific. The code samples appear to have been HTML encoded. This is a declaration that compiles:

 DECLARE_DYNAMIC_MULTICAST_DELEGATE_OneParam(FDramaWithFriends_OnEventConfig, const FDramaEventConfig&, NewEventConfig);

Howdy - just noting a broken/missing video link, step 11 from this page - https://docs.unrealengine.com/en-US/…Sub/index.html

and again same error at step 14

Cheers!

Hi there, you might want to double-check this, but I think the module name is incorrect on this page:

https://docs.unrealengine.com/en-US/…ule/index.html

It is not HttpServer. It is HTTPServer, like the folder in the include file. HttpServer would compile for me but not package. HTTPServer packaged.

If you look in the file HttpServer.Build.cs, you’ll see the module declared: public class HTTPServer : ModuleRules. It’s a mixed case aerial turkey-romp, but the packager needs the class name.

It should be great to comment every page to ask precision !
Thanks for all
Julien

HI, suggestion at least for newbies to Source Control.
Under source control and perforce there isn’t much info on what ‘files’ to add to server ( local host here), given:

“To submit something, first right-click on the change list and then select Submit. Then enter a change list description and click”.

Doing this all for the first time literally, that’s very vague. Many of us are creating landscapes , some small games etal, so something using those at least as an EX, would be very helpful, bc atm I ve no idea where to even start , for sure.

Being unsure isn’t healthy in this game.

ty

I’ve followed the steps on that page (Exporting Pro Media Files | Unreal Engine Documentation), but it still doesn’t show up as an option:

I’ve also followed the docs for using the Movie Render Queue Output Formats (Movie Render Queue Output Formats | Unreal Engine Documentation), and these instructions don’t work, either. I’m using 4.26.1, though it wasn’t working in 4.26 either. Here’s what I see for output options inside the Movie Render Queue (note that Final Cut Pro XML is not the same as ProRes):

The networking overview page: Networking Overview | Unreal Engine Documentation

Has a “Multiplayer Programming Quick Start” link in “See Also” that is currently broken: https://docs.unrealengine.com/en-US/InteractiveExperiences/Networking/Quickstart/index.html

Hello, the image is still not available, it still says An example hardware layout with three render nodes(h:600)](incameravfxdiagram.jpg)

Thank you

After I had open any image and then close it, I am not able anymore to scroll page until refresh

Nothing has changed in a year …
are you sure that feedback isn’t useless ?

Wrong image for step 6:

This image is supposed to show how you decrement ammo, but it is a repeat of the previous step.

How are people supposed to learn the engine and how to use it when the basic how to documents like character movement are not even up to date?

https://docs.unrealengine.com/en-US/…ers/index.html

Code on this page is untested and probably not even read after writing. There are errors like “TArray UVTransforms” and “TArray<type>”

Also, weird style of writing “class” in member variables declarations

**UPDATE: **someone finished the code already and it seems to work: GitHub - Luis24989/SkeletalMeshMerger: Plugin tha merges skeletal meshes at runtime, good for procedural skeletal meshes I only had to remove lines 83 and 84 from header to make it compile and replace AddInitialized with AddDefaulted in cpp to prevent it from crashing

Is there any way to access the old C++ API reference documentation? It did provide example code and more extensive information, really valuable to get to know some methods. The new version of the reference seems quite poor and incomplete compared, probably until it’s finished, but in the meantime it would be good to have access to the previous version. Thank you

Niagara docs/examples are for older version? 4.26.1 slightly different than documents