Download

Feedback on the new docs site

Usually the documentation work fine and it’s amazing! But now I’ve been trying to follow this doc for hours on end and it just doesn’t work. My computer was clean formatted, I tried on unreal 4.25.4 and 4.26, neither worked. Also I don’t get the same packaging options in my project, I don’t have ETC1.

I fine combed the documentation, I’m inclined to think it needs a revision!

Spec: Windows 10 with a Lenovo P1 2019 with a Quadro P2000. The android Nougat (API 25) device I used is a Samsung Galaxy J3 2016.

Setting Up Your Android Device For Development | Unreal Engine Documentation (No issue with this one)

Android Quick Start | Unreal Engine Documentation (completed all these steps without problem)

Setting Up Android SDK and NDK for Unreal | Unreal Engine Documentation (I only get DXT, ETC2 and ASTC in the packing options)

Hi there docu-friends :slight_smile: Hey, the toolchain links don’t work on this page because of a mixed-content error. The error is because serving http links from httpS pages is insecure:

Mixed Content: The site at ‘<URL>’ was loaded over a secure connection, but the file at ‘<URL>’ was redirected through an insecure connection. This file should be served over HTTPS. This download has been blocked. See <URL> for more details.

No worries @echo_four, yes right-click works for me. Thank you!

Hi,

Page: Referencing Actors, paragraph “Direct Blueprint Communication Referencing” after executing all the steps from the example expected result was reached, but with errors.

Log:



Blueprint Runtime Error: "Accessed None trying to read property TargetBP". Blueprint: Blueprint_Effect_Fire Function: Execute Ubergraph Blueprint Effect Fire Graph: EventGraph Node: Deactivate
Blueprint Runtime Error: "Accessed None". Blueprint: Blueprint_Effect_Fire Function: Execute Ubergraph Blueprint Effect Fire Graph: EventGraph Node: Deactivate


Thx <3

I was trying to find some C++ documentation for physical material, and the two links I found does not seem to work:
https://docs.unrealengine.com/en-US/API/Runtime/Engine/PhysicalMaterials/UPhysicalMaterial/index.html
https://docs.unrealengine.com/en-US/API/Runtime/Engine/PhysicalMaterials/UPhysicalMaterial/DetermineSurfaceType/index.html
https://docs.unrealengine.com/en-US/API/Runtime/Engine/PhysicalMaterials/UPhysicalMaterial/SurfaceType/index.html

After some digging I found this link:

which in turn leads me to

which seems to be what I am looking for. But, again searching the docs led me to the links at the top which is not working.

This seems to be just a simple redirect, or just updating the links and replace “Engine” with “PhysicsCore”

Thank you!

Hello! just reporting some broken links to your png files. (near the bottom of the doc)

i cannot make 3d shot please give me awnser

The introduction is missing

The description of most the functions of **FCompression **is outdated or from deprecated functions.
https://docs.unrealengine.com/en-US/API/Runtime/Core/Misc/FCompression/index.html

There is a typo on this page: Material Editor Reference | Unreal Engine Documentation

should be

I know it has been brought up a few times, but I think it would be great to make the source of the documentation available on github, so the community can fix errors like this and submit PRs. It is much more streamlined than coming to a forum, and writing a comment about it…

I’ve got two more for you
https://docs.unrealengine.com/en-US/…tor/index.html

  1. The page also contains this sentence twice.
  1. The video below the

section does not work.

Every time there is a clickable image (E.g: Vertex Color Materials | Unreal Engine Documentation) when you click on it, then close it, you cannot scroll the page anymore. It also throws this error 62 times:


tracking.js:6 Uncaught TypeError: Invalid attempt to iterate non-iterable instance.
In order to be iterable, non-array objects must have a [Symbol.iterator]() method.
  at u (tracking.js:6)
  at Object.__blockIframes (tracking.js:6)
  at MutationObserver.observe.childList (tracking.js:6)

Tested in Chrome 88.0.4324.96 and Edge 87.0.664.75.

UMG Designer Quickstart docs appear to be out of date. UI does not match 4.26. Difficult to proceed. Looks like docs are 4.23 and Blueprint editor has changed significantly. Any ref to new UI?

The title on page Vivox Plugin | Unreal Engine Documentation
should probably read

On the bottom of this page: Normal Calculation Method | Unreal Engine Documentation
under

there is no image slider.

Epic games, please could you add bit more documents on this page: Mobile Patch Utility Nodes | Unreal Engine Documentation

How to use generate files.
How to patch using DLC. please!

Hi Epic Games, I was loking at some images on the docs.unrealengine.com website and when I come out of image fullscreen I cannot seem to scroll up and down on the page. I dont know if anybody else is getting this issue but the only way to get out of ir is to refresh the page.

Thanks, RBL Dripz

The documentation is misleading or outdated. In the last code example it states that “// Unreal Header Tool (UHT) will create GetMySparseClassData automatically.” which UHT doesn’t actually do. The documentation also doesn’t specify whether classes with SparseData actually create the sparse data at runtime, which is what I assumed when I read the documentation. I ended up having to use “GetClass()->GetOrCreateSparseClassData()” which does exactly what I thought the UHT “GetMySparseClassData” would do. Some clarification is needed.

Hey guys, the code formatting seems whack on these macros: Multi-cast Delegates | Unreal Engine Documentation

Exporting a cubemap with NVIDIA’s Photoshop tool has changed quite a bit, might be worth updating this article, the interface is much different now. Exporting Cubemaps | Unreal Engine Documentation