Download

FBX Issue: Not importing all key frames

I am following the 3rd person game (pre 4.8) video series https://wiki.unrealengine.com/Videos/Player?series=PLZlv_N0_O1gZS5HylO_368myr-Kg2ZLwb
( I just realized they have a pre and post 4.8 series- I am using 4.8.3)

Anyway, everything is working as it should (they included connotations for engine changes - a few hard to find buttons and renames but no biggie).

On to the problem:

FBX problem : I have imported my ‘Jump_start anim’.
It’s 4 keyframes (needs to be fast), The character crouching down, then springing up into a ‘cannonball’ pose. Works fine in Max.
When I import it the anim seems to skip the crouching movement and goes straight into the cannonball pose.

Have tried several import/export options but nothing seem to work. Is this a known issue? None of my other anims seem to be affected.


edit: read only because the game was running, DOH!

Another issue.

My ‘jump end anim’ which is only a few frames also (following my ‘jump loop’ anim which is one keyframe) seems to take at least 1 second to start (so he hangs in air) . I have the time remaining ratio set to 0.9 which means that the jump anim should be interrupted basically as soon as he touches ground. (I have also tried 0.1)
Either way he still hangs for a second.