Download

FBX Import - some joints work, some don't - what's up with that?

whether I import an animated model from Lightwave 2015 or Maya 2016 - once in UE4.10.4, I find that some joints (or bones) do not move the mesh, and the rest do as they are intended.

In both cases (Lightwave and Maya) the rigs are simple but work well their respective applications, and the FBX Previews as fully functional in ‘FBXConvertUI-2013’.

Once in UE4 I can edit the joints that did not come in animated, but I would really rather that the animation I import is complete from whichever application I create them in.

Can anyone shed some light on this for me?

Unreal 4.11 has solved the problem

The fbx animations from Both light wave and maya import with all bones/joints functioning

Hooray,!!!

I am on 4.10.4 and I am getting very odd behaviour, like certain skeletal bones not moving at all. I hope that update fixes it for me.

I thought I was missing some ‘vital’ operation during the FBX export…

Turns out Unreal was the problem and they seem to have fixed it, hope your issue is resolved by the update as well

For me the issue was something different. I tried to animate the root bone of my weapon but UE4 refused to do it, then I added a new root bone at the start of the hierarchy and it worked.