FBX Import Problems

Using both Unreal Engine 4.7.6 and Unreal Engine 4.8 Preview 2 I noticed that when importing an FBX mesh from Blender 2.74 the orientation is always set to -Y Forward when imported no matter which FBX Export settings are used in Blender 2.74.

I do not know if this is related to Unreal Engine not reading those values during import, or Blender’s Exporter not properly exporting the orientation information.

Another thing I noticed is that only Smoothing: Edge in Blender makes the smoothing warning in Unreal Engine during import go away.

In the picture the right mesh is the original BSP Created Static Mesh from Unreal Engine, it’s exported to FBX then imported into Blender and exported back to FBX and imported into Unreal Engine, the left mesh is the imported version.

Hi KnightTechDev -

I am not experiencing the same issue that you are. I created a Cone along the Positive X Axis, converted it to a Static Mesh then exported the cone. Opening in Blender then exporting with the settings below, the cone (assuming I increase the scale to 100) comes into 4.7.6 and 4.8 P2 with the correct orientation along the Positive X Axis.

Here are the Assets I used as well:


Thank You

Eric Ketchum

Yeah, those are similar settings except I turn off Add leaf bones because there aren’t any I’m not using cloth or physics constraint animations to the adaptive bones and not rigging it up for that, I turn off Baked Animation because there is no animation to use with the mesh. Since I’m only outputting mesh I choose Mesh Only, I have axis set same as you but the scale is 100.00, and I use Smoothing: Edges because anything else will give smoothing warnings when imported into Unreal Engine.

I’m using FBX import Scale: 1.00

The settings like what you have is what I use for when I output the mesh for 3D Painter where the normals are initially smoothed for the surface painting, so those values are initialized default values when calculated.