Download

FBX animation import

So I’m using Cinema 4D to make this character model. Everything was going fine got it imported and could see the animation running and all. Then I wen’t back to C4D to try and UV unwrap it and give it some basic textures. Did that and now I can’t import the animation. It gives this error.

Warning This does not contain any valid animation takes.
Warning Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the ‘Export Smoothing Groups’ option in the FBX Exporter plug-in before exporting the file. Even for tools that don’t support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.
Warning Could not find the bind pose. It will use time 0 as bind pose.
Warning Animation Stack C4D Animation Take does not contain any valid key. Try different time options when import.

Anyone have any ideas?

Seems like your fbx doesn’t contain any animation data -> could you post your export settings + how you import it? + Have you already tried to import everything together in one file (so skeletal mesh + animation)? :slight_smile:

I’ll take a screenshot of my export settings as I’m exporting. Though there’s definitely an animation sequence. I wonder if I’m just not exporting it properly(?)
screen.png

So I set the animation range when I was importing and it worked! Might be some sort of difference between Cinema 4D Studio and Visualize since I just upgraded. I tried going back and exporting a previous animation that I’d imported successfully and it gave the same error.