Failing to cook content for Mac dedicated server

I am attempting to build a dedicated server executable on OS X 10.9.
I am compiling a code-based project from the source build of 4.6.0.
I have created a GameServer.Target.cs file as specified in the documentation here:[A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums][1]

The server and client binaries successfully build from XCode. I can package and run the client without error. However, I get the following error when I try to package the server:


The only platforms that will actually cook are Mac and MacNoEditor. MacServer and MacClient fail with the same type of error.

The server returns: *The requested value 'MacServer' was not found.*

The client returns: The requested value ‘MacClient’ was not found.

I have tried a number of combinations here, but my cooking settings are currently as follows:

Under Package, I have tested 'Package and Store Locally', and 'Do not Package'. Neither setting seems to make a difference. Under deployment, I have tried changing the device variant from MacServer to MacClient, Mac, and MacNoEditor without success. Under Launch, I have tried launching as Dedicated Server and Standalone Client. Currently, my Deployment and Launch settings are as follows:

I have also tested this process with a fresh project created from the C++ FPS template. The results are the same.