Failed to connect to swarm agent, swarmagent.exe crashes alone

I’m going crazy trying to solve this problem with swarm agent. While attempting to build the lighting I get the error “failed to connect to swarm”. When I try to start the swarmagent.exe file itself I’ll see the icon for it pop up in the taskbar briefly, before disappearing.

I have been googling for days, I’ve read every suggestion on this error I could find. I’ve removed all .net files I can, using the .net cleanup tool, and reinstalled. I’ve ran repairs for .net. I’ve uninstalled and reinstalled UE4.16 twice, as well as 4.13, 4.14, 4.15. I’ve opened up the ports 8008,8009, as well as just disabling firewalls and antivirus software. I’ve deleted the cache in users/appdata for it. The logs I get for swarm agent are the same:

Starting up SwarmAgent ...
 ... registering SwarmAgent with remoting service
 ... registering SwarmAgent network channels
 ... initializing SwarmAgent
 ...... checking certificate
 ......... certificate check has failed
 ...... initializing cache
 ......... using cache folder 'I:\unreal engine\Epic Games\UE_4.16\Engine\Binaries\DotNET/SwarmCache'
 ......... recreating SwarmAgent cache staging area
 ...... initializing connection to SwarmCoordinator
 ......... using SwarmCoordinator on RENDER-01
[PingCoordinator] Determined that we couldn't ping the coordinator
[PingCoordinator] Coordinator ping failed
 ......... SwarmCoordinator failed to be initialized
 ...... initializing local performance monitoring subsystem

I’m getting nowhere with this though, and its holding me up from doing anything further. If anyone has any suggestions I would be most appreciative.

This can be closed as I just fixed the problem, however for anyone else with this issue, googling around that might see this heres what happened:

I ran event viewer and saw that it war faulting at a file associated with c++ 2005, MSVCR80.dll and its location. I tried several times to uninstall and reinstall the 2005 c++ files but it wouldn’t work. Just to test out some things though, I modified permissions and deleted the file, mainly to see if it game me a different error but all of a sudden deleting the file made it work! So I’m back in business.