Download

Factory Floor patchy...

Hey there just starting on myfactory UE4 project and just wondering if I’m missing something, ie this is just a simple floor static mesh made in Blender with 2 UV maps, placed the “rough_concrete_with_lines” Graph on it in Substance Designer, then imported all into UE4.

When I build the lighting quality at “Production” I’m still getting what seems to be seams, and patchy lighter and darker versions of it. Am I doing something wrong?

Screenshot_1.png

Here’s a closeup of what I’m talking about…

Screenshot_2.png

Thanks in advance.

I tried a checkered pattern on it too and it looks like this…

That’s an issue with the lighting system, separate objects get processed individually rather than together. The indirect lighting can have slight variations which can be clear when you have flat surfaces. To avoid this, make the entire surface as a single mesh. In your situation it will improve performance by having a single mesh since it will decrease draw calls. The main limitation though is that if it’s a large area then you can end up where you can’t get enough detail in your lightmap even at a high resolution, though that’s rare.

Thanks darthviper107

I guess I’m envisioning problems when it comes to the walls, ie I’d like to have them as modular, because some will have windows and some won’t etc.

ie in World of Warplanes would they have set their modular walls and roof up like where I’ve highlighted?

2ae68b7d9acda2ecb628136ed8677d91147c0597.jpeg

Is there tutorials that could help me out in this situation?

Thanks in advance.

This issue is solved two-fold.
Follow*this guide* I made a while back to get the correct Lightmaps working, which will fix the ‘bleeding’ that you see.
to fix the different-coloured tiles, you can place a ‘lightmass importance volume’ to cover your whole scene. This will help lightmass by baking the GI during a lighting build, which fixes this issue.

Thanks Construc_

I tried your guide which seems to have worked for the “bleeding” (thanks for that), although the different coloured tiles are still there even when I deleted the old ‘lightmass importance volume’ and replaced it with a new one.

567941b8346a37ba9faf7a6ee2f068e7366fa310.jpeg

fc9b749de41d28ea1f9347d3ceef43abb240c56d.jpeg

fee2f0e0d40ba4ad7b349869969417c2914f4770.jpeg

eb29c4ccbbb7e0002e56a30cc69a65b067536f56.jpeg

Do you have a material on your mesh. As the different colored tiles i can see from your screenshot are UE4’s default material that gets aplied when you have no material on your object.

It has nothing to do with bleeding, the issue is that there are parts of the lightmass process like smoothing which are processed individually, when you have a lot of indirect lighting on a mesh the smoothing causes a variation in the lighting compared to other meshes. You see this most in those cases where it’s a very simple mesh like just a square plane, if you have details that cover the seams then you won’t notice it, but on a large flat surface it needs to be a single mesh rather than making it from many pieces.

Your not going to notice those seams when there’s supports and walls in place. And the seams aren’t going to be as bad.

Well in the end I followed this tutorial https://www.youtube.com/watch?v=-sJsR0y7R8U (but didn’t really change my UV setup), I did notice when importing my mesh I had “Generate Lightmap UV’s” & “One Convex Hull Per UCX” on, so I turned those off. I kept my Mesh “Min Lightmap Resolution” & “Light Map Resolution” as 256. And changed my World Settings for “Static Lighting Level Scale” to 0.1 & “Indirect Lighting Smoothness” to 2. Are any of those settings going to be inefficient, anyhow I got this result…

Screenshot_1.jpg

Since you have those beams there it covers the seam so it’s not an issue

Yeah but the beams were getting the seam too, but now with these settings this seems to fix things :slight_smile: