Download

Export Skel mesh and animations from Blender 2.80 beta import into UE4 4.22.2 settings >>>

This worked for me. Zero errors.


  • Blender 2.80 beta skel mesh to UE4.22.2 :

Note that this is a skeleton that I created starting with a single bone (Root) and then

extruded the other bones out from it. Not Rigify.

  • Set your Scene up right before you do anything else!

(I made a correction. Scale of 1 and meters creates an error in UE4 when you try and

create a physics asset. You get a “bones are too small” error. Scale must be 0.01 and

in centimeters not meters. Someone told me that “Blender fixed this issue”. He doesn’t

know what he is talking about.)

Units:

  • Unit System: Metric.

  • Unit Scale: 0.01

  • Separate Units. no

  • Rotation: Degrees

  • Length: Centimeters (not meters)

  • Mass: Kilograms

  • Time: Seconds

  • Do animations on Skelmesh first before importing

or re-import skel mesh only after animation is done.

(Something changes with the skeleton after you do

animation on it and Unreal doesn’t like it).

  • Start range at 0 (not 1) and 30 fps.

  • Make sure you keyframe frame 0 exactly as you modeled it

in other words dont change the bones in any way on frame 0

and set your first keyframe “as is”. Make sure you

select all the bones.

  • Rename Armature to Root (with capital R and this

will show up as Root bone in UE4 skel).

I renamed the “Armature” to “Root” in the scene outliner

and nowhere else. Just by double left clicking on it

with mouse.

  • Very important. Before you export anything make sure
    you set location, rotation, scale and scale&rotation of
    everything you want to export (meshes and armatures) by
    hitting Control+A (in object mode). Also very important,
    note that the moment you do that your transform widget will
    line up with the 0, 0, 0 point (origin) of your 3D workspace.
    So if your model is not centered on that point of origin
    then your transform widget in Unreal will be at an offset
    from the actor you imported and then it can be hard to move
    it around in the viewer of Unreal. So what I do if I have
    multiple objects I move each one so that its centered on that
    point of origin and then I apply the transformations. Its
    a little bit of a drag because now you have objects on top
    of each other inside Blender but it makes moving them around
    and placing them on maps in UE4 a lot easier. If you do not want
    to lose your relations between objects inside Blender then you
    can just save as another version with Blender and use the
    other version to apply transformations and export.
    So if you have to go back to Blender then go back to the scene
    where you have all your models in relative locations to each other.
    Then save as another version again and move each object on top
    of the point of origin before applying transformations and exporting
    one by one.

  • Exporting Skel mesh only from Blender:

  • Turn everything off in outliner for

other collections.

  • Select both skeleton and mesh.

  • Z up.

  • X forward.

  • Scale 1. (Don’t confuse this with scene scale. This means that the scale you selected in your scene settings

stays exactly the same. So if you selected 0.01 and centimeters you are exporting X1 that. Which means you are

not scaling it up or down from the original scene scale setting.)

  • Set smoothing to “Faces” (To avoid UE4 smoothing error on import).

  • Main:

  • selected objects. yes

  • active collection. no

  • Geometry:

  • Apply Modifiers. yes

  • Use Modifiers Render Settings. yes

  • Armatures:

  • Everything. no

  • Animation:

  • Everything. no

  • Select Armature and Mesh for export.

  • Importing skel mesh only into UE4:

  • Skeletal Mesh. yes

  • Import Mesh. yes

  • Geometry and Skinning Weights.

  • Select skeleton “clear” (so it generates new skeleton).

  • Vertex Color Import … ignore

  • Update skeleton Reference. yes

  • Use TO as Ref Pose. yes

  • Preserve Smoothing Gro. yes

  • Import Meshes in Bone. yes

  • Normal Import Method. Compute Normals

  • Normal Generation Method. Mikk TSpace

  • Import Animations. no

  • Import Meshes in Bone … yes

  • Import bone Tracks. yes

  • Remove redundant Keys. yes

  • Convert Scene. yes

  • Override Full Name. yes

Then click on Import All (not Import).

  • Exporting Anim only from Blender:

  • Turn everything off in outliner for

other collections.

  • Select both skeleton and mesh.

  • Z up.

  • X forward.

  • Scale 1. (Don’t confuse this with scene scale. This means that the scale you selected in your scene settings

stays exactly the same. So if you selected 0.01 and centimeters you are exporting X1 that. Which means you are

not scaling it up or down from the original scene scale setting.)

  • Main:

  • selected objects. yes

  • active collection. no

  • Geometry:

  • Apply Modifiers. yes

  • Use Modifiers Render Settings. yes

  • Armatures:

  • Everything. no

  • Animation:

  • Everything. yes

  • Select Armature only for export.

  • Importing animation only into UE4:

  • Select skeleton to apply anim to.

  • Import Meshes in Bone … yes

  • Set range - set range 0 - whatever.

  • Use default sample rate - yes.

  • Import custom attr … yes

  • Import Bone Tracks. yes

  • Remove red keys. yes

  • Convert scene. yes

  • Override full name. yes

Then click on Import All (not Import).


Setting the scale to 0.01 is still required. If you don’t do this it will look like the model imported correctly. But it’s scale will be incorrect relative to the rest of the objects in the editor. To test this add a socket to the root of your imported character and attach a temporary mesh like the original SK_Mannequin. You will see the difference in scale.

Yes you are right. I was just going to correct that. Someone lied to me and told me “Blender fixed that issue” TY

Or you could use my free plug-in to export/import and not really worry about much of anything.
By design, if you work with the mannequin or an exported animation it will automatically bake the final position and re-export. This means it takes care of applying loc/rot/scale for you.

I’m planning some further releases as well, but I have also included a button or 2 that are specifically intended for working with non mannequin things.

I have not had any of the issues you are mentioning about unreal not liking it or whatever in the past 3 weeks that I have been working pretty much full time at the plug in and video game…

Download here:
http://mosthostla.com/gamedev

Great thanks I downloaded it I will try it out some time :slight_smile:
Thank you.

Confirmed working for Blender 2.81a and UE4 4.24.3
Thanks!

Great thanks.