Download

Event Receive Draw HUD doesn't get proper screen coordinates in 4.12.4

While 3D Widget rendering in VR (when parented directly to the camera) is broken, I draw global menu activation progress bar and crosshair in the HUD:

ue4_draw_HUD_issue.png
Full: https://s32.postimg.org/892f3rdub/ue4_draw_HUD_issue.png

That worked perfectly fine in 4.11.2 and both crosshair and progress bar were drawn dead in the center of the screen in Gear VR. However, in 4.12.4 same BP draws stuff off-centered in VR, but centered in PIE.

Here is VR capture: https://youtu.be/7hmKAtvAKpo?t=1m29s

Sounds like a bug. Please let me know if it is and I will file it over at AnswerHub.

Submitted [Gear VR] Event Receive Draw HUD doesn't get proper screen coordinates in 4.12.4 - UE4 AnswerHub

I feel your pain, I have the same issue - https://answers.unrealengine.com/questions/445396/gearvr-hud-is-misplaced.html
This has been broken since 4.12.2 or so (I’ve already got 2 or 3 minor updates and it is not fixed).

Have you found a workaround/fix?

Also, could you please tell me how you implemented full-screen fade? Regular Start Camera Fade / Set Manual Camera Fade don’t work w/o Mobile HDR.

Nope, it’s a bug needs fixing (or maybe there is another way of doing it in VR I don’t know about).

For screen fading, I used same method these guys used: Creating Escape Velocity for Samsung Gear VR: A Postmortem - Unreal Engine However, since HDR is supported now, you can use regular ways of doing it.

Same bug in my project…i put a plane in front of the camera without HUD

Please upvote reported bugs in answerhub (either mine or motorsep’s) for Epic stuff to pay attention to problem.

I’m having the same problem here.

Also, this problem with 3dWidgets might be related: 3dWidget Web Browser not working in Gear VR - UE4 AnswerHub

(or at least, it’s related that I’m seeing the webpage in an angle of the screen instead of the center of the screen)

Hi, I want to confirm that the same issue happens to my GearVR build in 4.12.5. It works perfectly in Editor with PIE but in GearVR it seems to be offset a little to the right. It works perfectly when I rebuild the project for 4.11.

Hi, I want to confirm that the same issue happens to my GearVR build in 4.12.5. It works perfectly in Editor with PIE but in GearVR it seems to be offset a little to the right. It works perfectly when I rebuild the project for 4.11.