Download

Errors building 4.11 engine with Clang

I’m attempting to build the engine using Clang on Windows as described in this thread.
I’m receiving a bunch of errors along these lines:


clang.exe : error : no such file or directory: '/D_CRT_STDIO_LEGACY_WIDE_SPECIFIERS=1'

Clearly there is something wrong with the command line being passed to the compiler. Has support for building with Clang regressed since the above thread, or should this be working?

I tried setting bUseVCCompilerArgs (in UEBuildWindows.cs) to true, which got rid of those errors but led to many others.

I’m using Visual Studio 2015, and have tried with the version of Clang specified in the linked thread, and also a more recent version (3.8), with the same issues.
The build configuration attempted was Debug Editor / Win64.

Any pointers appreciated.

– I should add that my ultimate aim is to build the engine for Android from source, since I want to be able to step into engine code while debugging a project running on the device, but it seems the pdb files for the Android build do not ship with the launcher version.