Error When Building Project "Could not produce UE4Editor-Social.dll"

Now I’ve seen many similar threads related to building errors, but none have mentioned a problem producing UE4Editor-Social.dll.
I’m using Windows 7 Ultimate and running Microsoft Visual Studios 2013 Ultimate SP1, and I’m trying to build the Unreal Tournament project (for the Unreal Tournament Editor) and everything in the project builds just fine except for one item “UE4Editor-Social.dll”. Everything else completes fine including the additional Lightmass and ShaderCompilerWork projects.
The error I get after the build (which is usually many hours long) is:
6> -------- End Detailed Actions Stats -----------------------------------------------------------
6>ERROR : UBT error : Failed to produce item: C:\New UT Editor\UnrealTournament\Plugins\Social\Binaries\Win64\UE4Editor-Social.dll
6> Total build time: 7399.30 seconds
6>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(43,5): error MSB3075: The command “…\Build\BatchFiles\Rebuild.bat UnrealTournamentEditor Win64 Development -waitmutex” exited with code 5. Please verify that you have sufficient rights to run this command.
========== Rebuild All: 5 succeeded, 1 failed, 0 skipped ==========

I’ve been scouring everywhere online but it seems there could be hundreds of variables and combinations of problems that would cause this type of issue.
Basically, I’d like to know if there’s some SDK or some Visual Studios tool I’m missing, or some building procedure I’m not following.
I’m selecting Development Editor and x64 before building, and I’ve tried running the solution as administrator, I’ve disabled Avast and my firewall, I’ve tried rebuilding various times, I’ve tried reinstalling Microsoft Visual Studios 2013, and it’s still the same error.
All I want to do is just get back to working on the Unreal Tournament (4) Editor, but obviously when I try to launch it says its missing UE4Editor-Social.dll.

Any suggestions or help would be appreciated, thanks.

EDIT: Well I decided to delete all the files unzipped from the and just start over. I repaired Microsoft Visual Studios 2013, unzipped the files and then selected them all and clicked “Grant Full Admin Control”, and recreated the project files. This time it worked for some reason, as there was no error and I have been able to get into the editor without issues so far.