Error updating UE4 version using GithubDesktop

  1. I’ve forked UE4.13 when started my project some time in the past (used release branch of UE)
  2. My repo contains both engine and project code
  3. As time have passed I’ve changed some code in editor and added some classes to the engine (and developing project as well of course)
  4. Recently I’ve decided to update to 4.15.1, but got stuck.

In GithubDesktop I press Update from EpicGames/release but receive error (see image). When I press ViewChanges nothing happens and I got 0 changes in changes tab. Not sure what to do here. Probably my setup was initially wrong.

p.s. I also got SourceTree and it has a lot more functionality, so instructions for SourceTree are also ok.

Output from source tree:

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch EpicGames

git -c diff.mnemonicprefix=false -c core.quotepath=false pull EpicGames release

 * branch            release    -> FETCH_HEAD

error: The following untracked working tree files would be overwritten by merge:
Please move or remove them before you can merge.

don’t know what PCLaunch.rc2 is

It worked after removing this file.

I too am having this same error message regarding :Engine/Source/Runtime/Launch/Resources/Windows/PCLaunch.rc2
So is it ok to find and remove this file and then redo the pull?