Download

Error Packaging Project

I am having issues packaging my project.
This is what Im seeing:
LogMeshReduction: No automatic skeletal mesh reduction module available
LogMeshReduction: No automatic mesh merging module available
LogMeshMerging: No automatic mesh merging module available
LogNetVersion: EXE_Test , NetCL: 3573198, EngineNetVer: 2, GameNetVer: 0 (Checksum: 3197309913)
LogPackageLocalizationCache: Processed 7 localized package path(s) for 2 prioritized culture(s) in 0.078399 seconds
LogUObjectArray: 35825 objects as part of root set at end of initial load.
LogUObjectAllocator: 7529112 out of 0 bytes used by permanent object pool.
LogUObjectArray: CloseDisregardForGC: 0/0 objects in disregard for GC pool
LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
LogSubstanceCoreModule: Substance [CPU] Engine Loaded, Max Texture Size = 2048
LogTcpMessaging: Initializing TcpMessaging bridge
LogUdpMessaging: Initializing bridge on interface 0.0.0.0:0 to multicast group 230.0.0.1:6666.
LogMaterial: Uniform references updated for custom material expression Custom.
SourceControl: Source control is disabled
SourceControl: Source control is disabled
SourceControl: Source control is disabled
SourceControl: Source control is disabled
LogLinker: Warning: Can’t find file ‘/DatasmithImporter/Materials/DeltaGenMaster’
LogLinker: Warning: Can’t find file ‘/DatasmithImporter/Materials/DeltaGenMaster’
LogUObjectGlobals: Warning: Failed to find object ‘Object /DatasmithImporter/Materials/DeltaGenMaster.DeltaGenMaster’
LogLinker: Warning: Can’t find file ‘/DatasmithImporter/Materials/DeltaGenMasterTransparent’
LogLinker: Warning: Can’t find file ‘/DatasmithImporter/Materials/DeltaGenMasterTransparent’
LogUObjectGlobals: Warning: Failed to find object ‘Object /DatasmithImporter/Materials/DeltaGenMasterTransparent.DeltaGenMasterTransparent’
LogLinker: Warning: Can’t find file ‘/DatasmithImporter/Materials/DeltaGenMasterAbsorb’
LogLinker: Warning: Can’t find file ‘/DatasmithImporter/Materials/DeltaGenMasterAbsorb’
LogUObjectGlobals: Warning: Failed to find object ‘Object /DatasmithImporter/Materials/DeltaGenMasterAbsorb.DeltaGenMasterAbsorb’
LogLinker: Warning: Can’t find file ‘/DatasmithImporter/Materials/DeltaGenMasterClearCoat’
LogLinker: Warning: Can’t find file ‘/DatasmithImporter/Materials/DeltaGenMasterClearCoat’
LogUObjectGlobals: Warning: Failed to find object ‘Object /DatasmithImporter/Materials/DeltaGenMasterClearCoat.DeltaGenMasterClearCoat’
LogAndroidPermission: UAndroidPermissionCallbackProxy::GetInstance
LogOcInput: OculusInput pre-init called
LogEngine: Initializing Engine…
LogHMD: Failed to initialize OpenVR with code 126
LogStats: UGameplayTagsManager::ConstructGameplayTagTree: Construct from data asset - 0.000 s
LogStats: UGameplayTagsManager::ConstructGameplayTagTree: GameplayTagTreeChangedEvent.Broadcast - 0.000 s
LogAIModule: Creating AISystem for world Untitled
LogInit: XAudio2 using ‘Speakers / Headphones (Realtek Audio)’ : 6 channels at 48 kHz using 32 bits per sample (channel mask 0x3f)
LogInit: FAudioDevice initialized.
LogDerivedDataCache: Saved boot cache 0.08s 93MB C:/Users/IA_VR/AppData/Local/UnrealEngine/4.17/DerivedDataCache/Boot.ddc.
LogInit: Texture streaming: Enabled
LogEngineSessionManager: EngineSessionManager initialized
LogInit: Transaction tracking system initialized
BlueprintLog: New page: Editor Load
LocalizationService: Localization service is disabled
LogCook: Display: Max memory allowance for cook 16384mb min free memory 0mb
LogCook: Display: Mobile HDR setting 1
LogGameplayTags: Display: UGameplayTagsManager::DoneAddingNativeTags. DelegateIsBound: 0
LogFileCache: Scanning file cache for directory ‘D:/UE4 Files/EXE_Test/Content/’ took 0.01s
SourceControl: Source control is disabled
Cmd: MAP LOAD FILE=“D:/UE4 Files/EXE_Test/Content/FirstPersonBP/Maps/FirstPersonExampleMap.umap” TEMPLATE=0 SHOWPROGRESS=1 FEATURELEVEL=3
LightingResults: New page: Lighting Build
MapCheck: New page: Map Check
LightingResults: New page: Lighting Build
LogAIModule: Creating AISystem for world FirstPersonExampleMap
LogEditorServer: Finished looking for orphan Actors (0.000 secs)
Cmd: MAP CHECKDEP NOCLEARLOG
MapCheck: Map check complete: 0 Error(s), 0 Warning(s), took 154.299ms to complete.
LogFileHelpers: Loading map ‘FirstPersonExampleMap’ took 1.408
LogCollectionManager: Loaded 0 collections in 0.002533 seconds
LogFileCache: Scanning file cache for directory ‘D:/UE4 Files/EXE_Test/Saved/Collections/’ took 0.01s
LogFileCache: Scanning file cache for directory ‘D:/UE4 Files/EXE_Test/Content/Developers/IAVR/Collections/’ took 0.01s
LogFileCache: Scanning file cache for directory ‘D:/UE4 Files/EXE_Test/Content/Collections/’ took 0.01s
LogCollectionManager: Rebuilt the GUID cache for 0 collections in 0.000001 seconds
LogContentBrowser: Native class hierarchy populated in 0.0102 seconds. Added 2422 classes and 518 folders.
LogContentBrowser: Native class hierarchy updated for ‘WidgetCarousel’ in 0.0007 seconds. Added 0 classes and 0 folders.
LogContentBrowser: Native class hierarchy updated for ‘AddContentDialog’ in 0.0006 seconds. Added 0 classes and 0 folders.
LogContentBrowser: Native class hierarchy updated for ‘SceneOutliner’ in 0.0007 seconds. Added 1 classes and 2 folders.
LogSlate: Took 0.001624 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Slate/Fonts/Roboto-Regular.ttf’ (155K)
LogSlate: Took 0.001489 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Slate/Fonts/Roboto-Bold.ttf’ (160K)
LogSlate: Took 0.001684 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Editor/Slate/Fonts/FontAwesome.ttf’ (139K)
LogRenderer: Reallocating scene render targets to support 1060x568 Format 10 NumSamples 1 (Frame:1).
LogContentBrowser: Native class hierarchy updated for ‘HierarchicalLODOutliner’ in 0.0011 seconds. Added 1 classes and 2 folders.
LogLoad: (Engine Initialization) Total time: 33.08 seconds
LogLoad: (Engine Initialization) Total Blueprint compile time: 0.00 seconds
LogExternalProfiler: Found external profiler: VSPerf
LogExternalProfiler: Using external profiler: VSPerf
LogContentStreaming: Texture pool size now 1000 MB
LogSlate: Took 0.001757 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Slate/Fonts/Roboto-Light.ttf’ (159K)
LogAssetRegistry: Asset discovery search completed in 22.4966 seconds
LogCollectionManager: Rebuilt the object cache for 0 collections in 0.000000 seconds (found 0 objects)
LogCollectionManager: Fixed up redirectors for 0 collections in 0.000058 seconds (updated 0 objects)
UATHelper: Packaging (Windows (64-bit)): Running AutomationTool…
UATHelper: Packaging (Windows (64-bit)): Automation.ParseCommandLine: Parsing command line: -ScriptsForProject=“D:/UE4 Files/EXE_Test/EXE_Test.uproject” BuildCookRun -nocompile -nocompileeditor -installed -nop4 -project=“D:/UE4 Files/EXE_Test/EXE_Test.uproject” -cook -stage -archive -archivedirectory=“C:/Users/IA_VR/Desktop/EXE Test” -package -clientconfig=D
evelopment -ue4exe=UE4Editor-Cmd.exe -pak -prereqs -nodebuginfo -targetplatform=Win64 -build -utf8output
UATHelper: Packaging (Windows (64-bit)): BuildCookRun.SetupParams: Setting up ProjectParams for D:\UE4 Files\EXE_Test\EXE_Test.uproject
UATHelper: Packaging (Windows (64-bit)): Project.Build: ********** BUILD COMMAND STARTED **********
UATHelper: Packaging (Windows (64-bit)): CommandUtils.Run: Run: C:\Program Files\Epic Games\UE_4.17\Engine\Binaries\DotNET\UnrealBuildTool.exe EXE_Test Win64 Development -Project=“D:\UE4 Files\EXE_Test\EXE_Test.uproject” “D:\UE4 Files\EXE_Test\EXE_Test.uproject” -NoUBTMakefiles -remoteini=“D:\UE4 Files\EXE_Test” -skipdeploy -noxge -generatemanifest -NoHotR
eload
LogSlate: Took 0.000966 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Editor/Slate/Fonts/DroidSansMono.ttf’ (77K)
UATHelper: Packaging (Windows (64-bit)): CommandUtils.Run: Run: Took 1.4679035s to run UnrealBuildTool.exe, ExitCode=0
UATHelper: Packaging (Windows (64-bit)): CommandUtils.Run: Run: C:\Program Files\Epic Games\UE_4.17\Engine\Binaries\DotNET\UnrealBuildTool.exe EXE_Test Win64 Development -Project=“D:\UE4 Files\EXE_Test\EXE_Test.uproject” “D:\UE4 Files\EXE_Test\EXE_Test.uproject” -NoUBTMakefiles -remoteini=“D:\UE4 Files\EXE_Test” -skipdeploy -noxge -NoHotReload -ignorejunk
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe
UATHelper: Packaging (Windows (64-bit)): CommandUtils.Run: Run: Took 4.881492s to run UnrealBuildTool.exe, ExitCode=5
UATHelper: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.CommandUtils+CommandFailedException: Command failed (Result:5): C:\Program Files\Epic Games\UE_4.17\Engine\Binaries\DotNET\UnrealBuildTool.exe EXE_Test Win64 Development -Project=“D:\UE4 Files\EXE_Test\EXE_Test.uproject” “D:\UE4 Files\EXE_T
est\EXE_Test.uproject” -NoUBTMakefiles -remoteini=“D:\UE4 Files\EXE_Test” -skipdeploy -noxge -NoHotReload -ignorejunk. See logfile for details: ‘UnrealBuildTool-2017.10.05-11.14.05.txt’
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary2 EnvVars, SpewFilterCallbackType SpewFilterCallback) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.CommandUtils.RunAndLog(CommandEnvironment Env, String App, String CommandLine, String LogName, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary2 EnvVars, SpewFilterCallbackType SpewFilterCallback)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, String CommandLine, String LogName, Dictionary2 EnvVars) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, FileReference Project, String Target, String Platform, String Config, String AdditionalArgs, String LogName, Dictionary2 EnvVars)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.UE4Build.BuildWithUBT(String TargetName, UnrealTargetPlatform TargetPlatform, String Config, FileReference UprojectPath, Boolean ForceMonolithic, Boolean ForceNonUnity, Boolean ForceDebugInfo, Boolean ForceFlushMac, Boolean DisableXGE, String InAddArgs, Boolean ForceUnity, Dictionary2 EnvVars) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.UE4Build.Build(BuildAgenda Agenda, Nullable1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean InForceNoXGE, Boolean InUseParallelExecutor, Boolean InForceNonUnity, Boolean InForceUnity, Boolean InShowProgress, Dictionary2 PlatformEnvVars, Nullable1 InChangelistNumberOverride, Dictio
nary2 InTargetToManifest) UATHelper: Packaging (Windows (64-bit)): at Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL, ProjectBuildTargets TargetMask) UATHelper: Packaging (Windows (64-bit)): at BuildCookRun.DoBuildCookRun(ProjectParams Params) UATHelper: Packaging (Windows (64-bit)): at BuildCookRun.ExecuteBuild() UATHelper: Packaging (Windows (64-bit)): at AutomationTool.BuildCommand.Execute() UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Automation.Execute(List1 CommandsToExecute, Dictionary2 Commands) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Automation.Process(String] Arguments) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Program.MainProc(Object Param) UATHelper: Packaging (Windows (64-bit)): at AutomationTool.InternalUtils.RunSingleInstance(Func2 Main, Object Param)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Program.Main()
UATHelper: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=5 (5)
UATHelper: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults: Error: Unknown Error

Any Ideas?

When looking at your log the only line that stands out to me is the following one.

UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe

This saying that when it went to use the Unreal Build Tool or UBT, it could not find the 32-bit version of the compiler that should be in your VS folder. After doing a Google search with the error it looks like you could have one of the following issues.

https://answers.unrealengine.com/questions/545787/error-no-32-bit-compiler-toolchain-found-in-cprogr.html

https://answers.unrealengine.com/questions/527489/updating-from-49-to-414-with-2015-community-i-get.html

https://answers.unrealengine.com/questions/538803/error-no-32-bit-compiler-toolchain-found-in-visual.html

One thing that each of the above posts looks to have in common is that during the install only 64-bit tools where installed. If that is the case you can download the tools from here:

http://landinghub.visualstudio.com/visual-cpp-build-tools

Hope it helps!

thanks ill give it a try