Error code : IS-PQR23 while installing UE 4.17.2 on windows 8.1

After downloading UE4.17,2 , I faced this error (IS-PQR23) and I was unable to install. Here is my Specification :

I installed DirectX June 2010 SDK but still i faced that same error.
Can you please refer me which version of UE will be compatible with my system?