Epic Game launcher crashes on startup

Not sure if this will help, just thought I’d throw this out there.

Try a clean startup? How to perform a clean boot in Windows

It use to be easier to do but the simplicity of windows 8.1 made it so much harder…makes sense.

My machine:

  • Windows 8.1 pro (up to date With windowsupdate)
  • Nvidia GTX 970 (latest drivers)
  • Intel Core I7-4790K CPU @ 4.00GHz
  • 16GB Ram
  • SSD disk on C: standard spinner on D:
  • 2 screens (extended)

This is what happens

I install Epic Game launcer (msiexec /i EpicGamesLauncherInstaller-2.3.0-2604750.msi)

First startup of Epic Game Launcher

i Log in (tested offline too, same result) and i can click the

Fortnite - link and everything appears fine

Unreal tournament - link everything appears fine

Unreal engine - The Launcher shuts Down (at first Windows hooked up a “Your program has stopped working”, however after following guide on how to debug EpicGameLauncher (and manually removing epic games in registry) it just shuts Down.

Second startup on all thereafter

the login screen appears
enter credentials and click sign in
Please wait comes up and then it Closes

If I uninstall EpicGameLauncher and install it again. It is the same thing all over. First login everything seems fine until clicking unreal engine link. It shuts Down and same thing all over again. after login screen it shuts Down.

There is nothing in the Eventlog what so ever that something has gone wrong. The EpicLauncherlogs (even With debug) seems to just stop in the middle of what they are doing at random Places. sometimes on downloading to Queue and sometimes before. The dxdiag looks fine. I have Attached the logs.

This is what i have tried.

  • Followed the troubleshooting page
  • removed launcher With msiexec
  • extended removal in registry
  • defrag
  • bootoptimizer
  • registry cleaner
  • added epic games Directory to exluded Directory for Ad-Aware Antivirus
  • Set UAC to lowest (since i run Windows 8.1, setting DEP is not an option)

I have come over a few post where People seem to have similar problems, however none of the solutions provided has so far given me any success.
What i have not tried is a clean install of Windows 8. This i would really like to avoid.

link text

Well what do you know :slight_smile:

I had already started disabling services for startup in msconfig when i read your post.
did not work, however.

when i did this.

Msconfig - chose diagnostic startup. (it will start without network, but do not worry, and next time you start msconfig it will show something like selectiv startup, but never mind that)

restarted computer -

startet EpicGameLauncher again - it now come with an error with something like cannot read version (because of no network)

opened cmd with administrative rights. uninstalled Launcher. Installed it again

startet launcher (as expected same cannot read version error).

msconfig - choose normal startup.

restart computer.

started launcher and chose - offline -

Clicked Unreal Enginge (and now it worked)

Logged on

download started.

Looks like it was something in my startup that removing sevices and startup normal fixed.

thanks B16redlined. :slight_smile:

Try what i did (post below). (download EpicGamesLauncer installer first again to be sure)

That not work… i have same issue here…

Good to hear. Hopefully this will help others having the same problem.

BTW, can you mark this solved, please.

To install / uninstall at command window (CMD)
msiexec /i fulllauncherinstallationfilename

I can confirm that this fix does not work for the Windows 10 issues. :’(