Download

Engine suddenly will not package or cook anything

UATHelper: Packaging (Windows): Execution of commandlet took: 3.40 seconds
UATHelper: Packaging (Windows): LogShaderCompilers: Display: === FShaderJobCache stats ===
UATHelper: Packaging (Windows): LogShaderCompilers: Display: Total job queries 0, among them cache hits 0 (0.00%)
UATHelper: Packaging (Windows): LogShaderCompilers: Display: Tracking 0 distinct input hashes that result in 0 distinct outputs (0.00%)
UATHelper: Packaging (Windows): LogShaderCompilers: Display: RAM used: 0.00 MB (0.00 GB) of 819.20 MB (0.80 GB) budget. Usage: 0.00%
UATHelper: Packaging (Windows): LogShaderCompilers: Display: ================================================
UATHelper: Packaging (Windows): LogHttp: Display: cleaning up 0 outstanding Http requests.
UATHelper: Packaging (Windows): LogContentStreaming: Display: There are 1 unreleased StreamingManagers
UATHelper: Packaging (Windows): Took 10.0617924s to run UnrealEditor-Cmd.exe, ExitCode=1
UATHelper: Packaging (Windows): ERROR: Cook failed.
UATHelper: Packaging (Windows): (see C:\Users\user\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_5.0EA\Log.txt for full exception trace)
UATHelper: Packaging (Windows): AutomationTool exiting with ExitCode=25 (Error_UnknownCookFailure)
UATHelper: Packaging (Windows): Updating environment variables set by a Turnkey sub-process
UATHelper: Packaging (Windows): The system cannot find the path specified.
UATHelper: Packaging (Windows): The system cannot find the path specified.

This occurs regardless of project. It can be empty but this still happens.

Steps I would take

  1. Copy all contents and levels into a new, clean project and see if it packages there.
    If that doesn’t work,

2.Validate Your version of Unreal and repeat #1
If that doesn’t work, I’d go into every script/blueprint and make sure nothing is corrupted

1 Like

The going into every script/blueprint and make sure nothing is corrupted part helped a lot, thanks!