Download

Engine association is different for 4.24.1 Windows and Linux builds

I have built out the Linux version of the 4.24.1-release tag in the UnrealEngine repository from github. UE4Editor runs fine on Ubuntu 19.10. Saving a project on Linux causes a UUID to be written to the EngineAssociation field of the .uproject file; whereas, on Windows the official 4.24.1 download writes the .uproject file with “4.24” in the EngineAssociation field. This difference between UE4Editor on Windows and Linux causes UE4Editor to believe that projects must be converted between Windows and Linux.

Is it really the case the UE4 file formats are really different between Windows and Linux or is there a way to have the Linux version write “4.24” to the EngineAssociation field in the .uproject files? An informal and clearly inconclusive test shows that changing the Linux UUID in the EngineAssociation field to “4.24” allows the file to be read on Windows with no conversion.

Doug Service

We are experiencing the same issue on 4.24.2. It is really inconvenient, as some people in my team work on linux and some on windows. Can someone from the dev team comment on this?

Same here, still not fixed. Is is safe to just press the “skip conversion” button and continue to work as normal?

Because one of the maps I was working on in a previous project (this could’ve been for another reason I’m not 100% sure) was not present when opened on windows after creating it on linux. I believe I may have tried ‘convert in place’?

How does your team combat this issue?

So for my current project, I’m still not sure whether it’s a good idea to skip conversion in case it breaks something down the line/breaks a config somewhere?