EnableRootMotion does not work.

Hello, everyone!
When I turn on EnableRootMotion, the RootMotion animation can be correctly displaced in the X and Y directions, but the height of the Z axis does not work, including some animations in Unreal Mall. This is why?

Because you need Flying enabled for Z displacement to work.

Thank you!

Excuse me, how to enable the Z axis? I didn’t find the relevant settings…

Movement component set flying.

Thank you. I’ll study it right away.