emissive materials causing light leak.

i am modeling an office building and tried to use emissive material for all the lighting fixtures instead of light objects to save time and resources. however the emissions leak through walls. is there a way to fix this or am i going to have to use light objects instead? am i going to have processing problems with about 50 light sources? is there a proper way to do this?

edit: i rendered at medium quality and it seemed to reduce the problem. so perhaps a full quality render will fix this.

66cca82567f5b7a3539c5e9fbf9c8ae89470a58b.jpeg

Make sure your lightmap resolution is high enough, also make sure that the walls/ceiling/floor don’t extend beyond each other, if they do then the overlapping part can cause shadow/light to bleed over to the visible area. Also, you might want to try removing the skylight and using the Environment settings in the global lightmass properties.