Editor stuck at loading after modifying any asset

Hello, I’ve got a problem with editor being stuck at loading at exactly 72%. Issue occurs when I modify an asset (it happens with all kinds of assets: animations, montages, data tables etc.), save it and then restart the editor. It is very hard to pin point an asset that cause the issue, especially that there is no error in output log.

I tried to investigate what cause the editor being stuck so I paused the execution of the program when it stoped at 72% and the line editor was stuck at was inside WindowsPlatformProcess.cpp inside Wait function:

return (WaitForSingleObject( Event, WaitTime ) == WAIT_OBJECT_0);

One workaround I found is to copy the troublesome asset and work on that copy. For some reason, the copy of that file works perfectly fine although it is not a solution since it’s very hard to find troublesome asset if you modify tens of assets before you restart the editor.

Issue occurs on any engine version, checked on: 4.22, 4.23, 2.24.

I’ve also tried renaming the asset but it didn’t work. This issue drives me crazy and cost me a lot of time so would love to hear any solution to that.