Editor not responding to perforce properly

First problem is whenever I open my project, perforce is not connected by default and I have to set it up every time, i opened the project. Is there some setting that m missing?
Other problem is, when my colleague opens the same projects, “Status icon” doesn’t appear on any of the files. But when he hover the mouse to that particular asset, it does show that final is checked out by this user.

Please let us know, if there some setting we are not setting it up.



With the default setup, you will need to enter your Perforce credentials for each new project you create. If this is a problem, then you can enable the ‘Use Global Settings’ preference in Editor Preferences->Loading and Saving->Source Control. All projects you work with locally will then share the same source control settings. Note that this will require you to log in again.

As to your second issue, does this occur only just after logging in? File status is cached to reduce server bandwidth, so the indicator icon may not change unless you right-click and force a refresh with Source Control->Refresh.

Note also that no icon being displayed usually means that the file is ‘pristine’ as far as source control is concerned.

I have recently found and fixed an issue where URLs with http:// (etc.) at the start were getting truncated to simply be “http:”. If you are getting this issue then the fix should be coming in 4.7.

Thanks for replying.
I have solved the first issue, as my entire project was in perforce and “SourceControlSettings.ini” file wasn’t checked out, Unreal Editor wasn’t able to write those perforce settings there so after checking out, it worked perfectly.

As for the seconds issue, we did tried to refresh and sync but sometimes “Status Icon” shows up, sometimes it doesn’t shows up.


This would be a good time to point out the guide in the docs to setting up your project for use with perforce as source control :slight_smile: