Editor navigation frustration!

It seems that every time you want to navigate while holding ALT - RMB in the editor, the camera gets stuck on an invisible ground collision plane and refuses to zoom or pan further, it simply refuses to move under this plane in negative space, you will be forced to move manually with the arrow keys or WASD to bypass the “ground” and then you are free again to use ALT and mouse to zoom/navigate.

Is there a way to disable that strange ground plane collision in perspective, why is there in the first place?

*Edit: Just discovered another strange behavior, turns out if you load your level and try to use the mouse ALT navigation to zoom/pan in, you will be stuck at near ground plane as mentioned above. But if you use arrow keys and track in to maximum zoom area you want to view your object and then switch to ALT-Mouse, then UE4 sort of “Memorizes” that zoom position and makes it default. at some random point in time later while working in the project it resets again.

Just frustrating. I have no words to describe this other than that.