Editor crashing on launch

Every time I try to launch the editor, it crashes before doing anything, stops responding, and I have to close it out. This has been happening since I installed both the launcher and engine V4.7.1 a few days ago. Any suggestions on what I should do?

Hey,

Have you updated to 4.7.2 yet? If not, could you please do so and see if you’re still experiencing an Editor crash? Also, were there any error messages included in the crash, or perhaps a callstack? If so, could you please provide those to me so I can look into this further for you?

Thanks!

I updated it to 4.7.2 today, still crashes on launch. It doesn’t give me any sort of error message, I press launch, and then the popup that says it stopped responding appears

Hey,

Could you please verify your version of the Engine within the Launcher? All you need to do is go to ‘Library’ and select the drop-down arrow that’s by ‘Launch’ and actually click ‘Verify’.

Another thing you can try is to locate where you installed the Engine and go to: Epic Games\4.7\Engine\Binaries\Win64 and locate ‘UE4Editor.exe’ and open it that way.

Now, if the .exe does not open, there is an issue with the Engine itself, which installed onto your computer and it may be beneficial to uninstall it and reinstall it. But if you can open it from the .exe and not through the Launcher, then the Launcher is having trouble and we will need to investigate that further.

If the Launcher is the one having trouble, please go here and provide us with the debugging : A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

Cheers!

I tried verifying, restarting, reinstalling, and every time it does the same crash on launch, no matter if I’m using the client or going directly to the exe, both times it waits for a few seconds, and then just says Unreal Engine has stopped working. Error code 0xc000001d

Hey,

Thanks for letting me know that the .exe and the launcher both aren’t letting you into the Editor. In order to assist you further, I’m going to need some . Please follow these instructions so I can get this resolved quickly for you. Also, if it’s not too much trouble, include your dxdiag as well, so we can insure all is well with your system specs.

Getting Debug :

There is a special log file that we require in order to troubleshoot the issue. To access this log, please open the Launcher and do the following:

  • In the top-right of the Launcher, click the Gear icon.
  • Select ‘Enable dubug logging’ and then choose ‘Enable Now’. If you issue occurs at launch or sign in, Select ‘Enable - debug logging’ and then choose ‘Restart’
  • Reproduce the issue your experiencing while the debug logging is on.
  • After Reproducing your issue go back to the Gear icon and select ‘show launcher log’
  • The Debugging will be the most recent backup file in the list.
  • Place this log in a Zip file and attach it to your AnswerHub report.
  • Back in the Launcher, select the Settings icon again and select ‘Disable debug logging’ or close your launcher.

If you have any trouble obtaining your , just let me know. :slight_smile:

Thank you!

Here it is [link text][1]

32679-.zip (523 KB)

Hey,

Thank you for providing me with the debugging , as well as your dxdiag for your system. The first thing I noticed is that you’re running on Windows Vista, which the Unreal Engine does recommend at least Windows 7 on your computer.

What are Unreal Engine 4’s system requirements?
For developing with UE4, we recommend a desktop PC with Windows 7 64-bit or a Mac with Mac OS X 10.9.2 or later, 8 GB RAM and a quad-core Intel or AMD processor, and a DX11 compatible video card. UE4 will run on desktops and laptops below these recommendations, but performance may be limited.

However, since you’re on Vista, I do know that others have had this trouble in the past. Here are some links referencing the 0xc000001d error:
Unreal Engine won't launch Error code (0xc000007b) - Getting Started & Setup - Epic Developer Community Forums Error when running UE4Editor.exe - the application was unable to start correctly (0xc000001d) - Platform & Builds - Epic Developer Community Forums Launcher error "Unreal Engine stopped working" - Platform & Builds - Epic Developer Community Forums Can't run UE4 - Platform & Builds - Epic Developer Community Forums

If you have any further questions, please do not hesitate to reply to this thread.
Thanks!