Download

Editor Crashing cause of a bool in a pawn blueprint.

My editor would crash when browsing to a file, all other files are ok but this one pawn bp will cause the editor to CTD with no crash report.

I’ve narrowed it down to which file and even down to a bool in the file.

The BP pawn has C++ code it inherits from and this bool pretty much transforms the character into another beast from human to animal basically so there is a lot of different stuff it handles.

Something to note is I just recently cloned my C drive to larger SSD. Everything seems to be ok though, OS, games, other projects so I’m not sure if this is related but I can’t see how.

Here is what I’ve done.

I’ve verfied the engine contents.
Deleted DervivedCached.
Fix up redirectors in folder.
Deletd the Intermediate and Saved folders
Rebuild and Regenerated Source.

Viewed the editor crash log but doesn’t seem to have anything useful.

I’ve also tried reverting to a known working commit (Since I have this under source control) but it too fails!
I’m ok with having to redo work in editor like animations, sounds,etc… but If its a source problem I have no idea how to begin to narrow it down.
At first I thought maybe something with the source but even after reverting to a stable branch with a known working version it still crashes.

Out of ideas and feeling really bummed out about this. I was on a role until I hit this snag.

Have you tried deleting the blueprint and remaking it? Blueprints sometimes get corrupted, I heard.

Yea I have, and the moment I check the bool in the BP it starts crashing the editor.
Need to figure out why.

What does checking the bool do? (i.e. what bp/code does it trigger)?

Lots of varying stuff.
Too many to list.
It basically changes the way the player is, from a regular person to a monster.
So it changes the move set, the player stats, and how they respawn.

Its been fine the entire time until something which has gone wrong recently (not sure what).
I’ve only done a vary small tweak to the code which was the way the stamina regen worked. The BP works fine, btw, I can get in game and everything is ok (can even test my code that way). Its just the moment I go to view the BP or try to open it, editor crashes.