Editor (4.9.2) Crashing on Project Load

Hi All,

Here’s an interesting case. At our small studio, we have UE4 on multiple PCs installed. We have our project versioned via SVN and we have donwloaded the SVN build to multiple computers. Here comes the interesting part:

  • out of 8 workstations, on 3, the editor crashes on load.
  • ALL workstations have the same software installed, same drivers, same hardware, same operating system, etc
  • we have tried deleting the caches as well, didn’t help
  • we tried restarting, reinstalling, re-acquiring the project, didn’t help

The crash report is as follows:

Unknown exception - code 00000001 (first/second chance not available)

"Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.9\Engine\Source\Runtime\Core\Private\HAL\FileManagerGeneric.cpp] [Line: 647]
Invalid BufferCount=0 while reading D://aqunoxSVN//Content//Maps//ANX_CaveMa

UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\misc\outputdevice.cpp:354]
UE4Editor_Core!FArchiveFileReaderGeneric::InternalPrecache() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\hal\filemanagergeneric.cpp:647]
UE4Editor_Core!FArchiveFileReaderGeneric::Serialize() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\hal\filemanagergeneric.cpp:686]
UE4Editor_Core!operator<<() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\misc\engineversion.cpp:188]
UE4Editor_CoreUObject!operator<<() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\coreuobject\private\uobject\packagefilesummary.cpp:201]
UE4Editor_AssetRegistry!FPackageReader::OpenPackageFile() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\assetregistry\private\packagereader.cpp:37]
UE4Editor_AssetRegistry!FAssetDataGatherer::ReadAssetFile() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\assetregistry\private\assetdatagatherer.cpp:422]
UE4Editor_AssetRegistry!FAssetDataGatherer::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\assetregistry\private\assetdatagatherer.cpp:186]
UE4Editor_Core!FRunnableThreadWin::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]

Hello ,

I looked up that crash in our database and it seems that it only occurs in 4.9.2. Could you try making a copy of the project and testing it in 4.10 to see if the same thing occurs? If you do get a crash in 4.10, could you post the callstack if it is different? That would explain why I don’t see any 4.10 occurrences.