Download

Dynamic light shadows wrong?

My static light is perfect, however as soon as I place a dynamic light (movable) into the scene it creates weird shadows or refuses to light certain objects.
In this case it is a section of the wall, and floor.

I have made sure the smoothing groups are correct, the lightmap resolution is 128 (more than high enough for a wall, do dynamic lights even use the lightmaps?)
There are also no overlapping UV’s…

What’s the issue? =/

Thanks for any help

9cd0b398ecf9d393488b37c1ffcd44abec9711a3.jpeg
wallissue.jpg

Solved: Normal maps were not using the correct compression setting.

Dynamic lighting doesnt care about the UV layout really. Yours was probably smoothing group/normals issue.

If you’re using normal maps then make sure that they are set to use normal map compression, you can have it automatically do that by adding _normal to the file name

So I jumped to conclusions with the UV thing, as the walls / floor were the only things that had tiling UV’s and the only ones with dynamic light issues… so frustrating when I realised it never fixed it. I’ll edit my last post so people don’t read the wrong ‘solution’.

Darthviper, all I have to say is… thank you! I would never have figured out that I needed to compress my normal maps to fix the lighting.
Saved me a big headache! Is there any info around, or if you’re willing to give a quick explanation as to how compression settings change the way lighting behaves? Does the same apply for roughness, metal maps and so on, as in specific compression for correct / best results?