Download

Drop-down Menus will not Drop Down

Hello, I am currently working on an RPG and I can not continue this because for some reason whenever I click on the drop down things, they will not drop down (i.e. File, Edit, Windows, Help) and in the Widget Blueprint editor, I can not choose a spot for my widgets to anchor down to because that is a drop down as well. Whenever I click them, the top of the engine lights up, but nothing happens. I have tried clicking over to the other page to see if they just were not popping up on my screen, but they are not popping up at all. I have tried the basic stuff like turning my computer off and back on, and restarting the program, but those have not seemed to work. If you look down below, I have a video showing everything that is going on. If you know how I can fix this issue, it will be appreciated. Thank you for your time!

https://youtu.be/PSVcdRl9U70

~Atlas Hyūga

Have you updated to windows 10 creators?

If so you need to run ue4 using a command prompt:
-d3D12 suffix

As in using a shortcut:

C:\Epic Games\UE_4.15\Engine\Binaries\Win64\UE4Editor.exe-D3D12

I am running win 10 home. Should I to update to creators?

No don’t bother, but if you upgrade you’ll have to use that suffix as the command your currently using to launch ue4 will not allow your menus to work correctly.

Plus it’s a pain in the proverbial watching it take a lifetime to update

But try adding the suffix, it might sort your issues

Like this or do I put the C:? I’m sort of new to this stuff so bear with me! (I colored out the name for security reasons)

I can’t open your attachment mate

Don’t be worried about asking questions that might seem simple, we’ve all got to learn and no one (with half a brain cell) will think otherwise, so don’t worry mate

If you’re using a shortcut to open ue4 from your desktop, right click on its properties to find out what command it’s using to open, it’ll most likely be identical to the shortcut I’ve listed, just add the -d3d12 bit at the end of it without a space and you should be good to go.

Prompt.PNG Sorry! Try this one

Also, I’m launching UE4 through the Epic Games Launcher. I do have a shortcut to that on my desktop, but not one that goes directly to UE4 without going through the launcher

If you open the directory in win explorer and create a shortcut to it from your desktop, right clicking on the eye should give the relevant option.

Then just right click the shortcut on your desktop and in properties just change the command to include the -d3d12 and it should run.