Does not work on Standalone, Works on Editor (PIE)

07-29-2018, 02:02 PM
I have been working on an RPG for too long, it has no errors and I managed to make it as optimized as possible.

Today, when trying the standalone, an actor component isn’t detected by the game anymore. It doesn’t even launch the event begin play or the event tick while everything works properly in the PIE
(-tried with delays
-upgrading from UE4.19.2 to UE4.20
-ticked autoactivate
-in the actor, on component activate shows that it’s activated at the beginning of the game, however, still same problem
-validating assets/fix up redirectors in folders/refreshing all nodes
-recompiled every bp one by one
-cleared the saved folder)
(yesterday it was working fine, it did this after shutting down and turning on the pc today)

also, upon checking if “is valid” it displays for me that it’s valid and it exists in both PIE and standalone but it seems like in standalone it is not working/ so probably desactivated.
the attachment : The component event tick, shows in the PIE and doesn’t show in the Standalone.

I worked on this for 1 year now, it’s not really pleasing to experience this…
Thank you in advance, I’d appreciate all the help!

Print Node is removed from ur build if your build set to shipping, as long as its development , you will see print messages .

Just set your build to Development or debug and you will see the print node just like inside the editor.

It’s already set to development.
As I mentioned, there is absolutely no function working in the component, not only abaout printing, my character has this component, that makes him attack, dodge, throw spells…etc
and all of that would work perfectly fine on editor but nothing would work on standalone