Download

DK2 not working in first person template in 4.11

Hi guys,

I’m going crazy over this… made a project using first person template in the attempt to benefit from stereo instancing for my Oculus work. But contrary to 4.10, the tracking just won’t work properly out of the box. It’s as if the camera was locked somehow. Tracking just moves a bit and camera is automatically forced back to center position no matter what. A bit like when hmd was locked during matinee sequence, if I remember correct: camera would be forced back to center. I try to circumvent this like I would on matinee sequence on the level blueprint doing something like this:
ce418c5d30dfde341df4adb196feff8e8946e010.png

But the “SET- follow hmd orientation” doesn’t seem to exist anymore!

I’m totally clueless…

Thanks in advance

This was happening to me, too. Messing with the existing camera and hmd settings didn’t have an effect. My workaround was to create a new character blueprint and copy and paste in the movement logic from the first person shooter template character. Once you override your game mode to use the new character, positional and head tracking should be back to normal until we get an official fix.

I’ll attach the blueprint later if you’re still having trouble.

In UE 4.11 there is a new “Lock to Hmd” checkbox in a Camera component and it is enabled by default, so head tracking should work out of the box on all cameras.

In the first person template, looks like it is overridden by “Use Pawn Control Rotation”. Disabling it works a bit (but not perfect. The gun also rotates).