Distance field shadow not work on masked material?

I am currently working on an exterior ArchViz project. For the sake of shadow quality, I use distance field shadow instead of cascade shadow. However, I encounter a problem with shadowing the masked material.
I made single plane with 2 tris and a masked material to make grass.
When I turn distance field shadow on, the shadow is still the shape of plane. The mask is not working.
Here is the screenshot of cascade shadow map:

The image below is with cascade shadow off, distance field shadow on:

I have already turn on the two-sided mode in material, model and foliage setting. It still doesn’t give me the masked shadow and shadows are flickering. I have tested on 4.11.2, 4.10.4. They all don’t work.
I also checked Kite demo, as I found that trees and debris are high detailed in model, they work just fine.
Another thing is that I have speedtree models in my scene, the shadow of speedtree leaves works fine. Only grass doesn’t work.