Display freezes when I click "Play"

Build Type: source build from GitHub

Build version: revision f44f8e5

Detailed description of the issue: The editor launches and I am able to interact with viewports. However, the moment I click “Play”, the display freezes. The display flashes a few times as (presumably) the display driver attempts to reset the GPU. Logging into the machine via SSH is still possible.

Screenshots/Link to video: not possible

Repro Steps:

  1. launch the editor
  2. choose one of the templates
  3. click “Play” to test the level

This is 100% reproducible and happens every time I attempt to play the level. I tried using both the amdgpu driver and the open-source radeon driver and the results are identical.

System Specs:

  • OS: Kubuntu 17.04 (kernel 4.10.0-20-generic)
  • RAM: 16 GB
  • GPU: AMD Radeon R9 270X (2 GB VRAM)

Attachments: dmesg output

Hey nathan-osman-

I downloaded the master branch and tried to play in the editor and did not have the editor freeze. Are you using the 4.16 branch or the actual master branch (which is currently 4.17)?

I thought I had checkout out the master branch but it appears that instead I am on this revision: https://github.com/EpicGames/UnrealEngine/commit/f44f8e5 (4.15.1?) I’ll try updating to master and rebuilding.

I switched to the master branch and performed a clean build. Now the editor doesn’t quite finish loading. As soon as the window for the editor appears, it immediately exits and the following is printed to the terminal:

link text

The master branch receives less testing than other branches and is more likely to have problems associated with it. I was only asking about master to confirm I was using the same engine version that you are. Looking at the log output, the issue may be due to your graphics drivers. If you are on an older version or beta drivers, please try updating to the latest released drivers. Also, for additional information, what drivers are you currently using?

I’m currently using the radeon driver bundled with the kernel. I also tried the amdgpu driver but it was no different. amdgpu-pro isn’t available for Ubuntu 17.04 yet, so I guess I’m out of options until AMD releases an update. The further I investigate this, the more it looks like a driver issue and not an issue with UnrealEngine.