Download

Disappearing/Reappearing 'Access None' Error Message

Hi All Masters and fellow developers,

A UE4 Newbie here (as to today one year and 8 months learning UE4 part-time). As I am toying with my own projectby following all the video tutorial from Youtube, I recently encountered a quite stubborn ‘Access None’ problem:
The function that I am trying to mimic is ‘rotatable 3d object inside UMG’. The video tutorial is very detailed and easy to follow (and thanks to the author PyroDev again and here is the link to the video Unreal Engine 4 - [PUBG] 3D Live Widget - YouTube). However, as I literally copied the tutorial frame by frame, the ‘rotation’ part just won’t happen.
Initially, the engine popped many ‘access none’ error messages. As I tried some ‘casting’, ‘promote to variable’ techniques, somehow stopped the error messages, but the rotation still doesn’t work. So I tried to use the ‘print string’ node to thieving out where the actual problem is, and the ‘access none’ error messages reappeared again.
I vaguely understand the causing of the infamous ‘access none’ error message – something to do with the ‘empty holder’ of callable actor/component/etc, and I tried to mess around with the GameMode too in order to make sure that the UMG is getting the input that is from the player controller.
After all these attempts, I am still stuck here: it is either ‘no print string node’ ‘no rotation function’ and ‘no error message’, or ‘with print string node’ ‘still no rotation function’ and ‘with lots of error message’.
I hope someone could shine some light on my problem.
Thank you very much.

Peter