Download

Disabling landscape lightmaps?

When I build lighting, why does the scene generate hundreds of lightmaps for the landscape (with static shadows disabled)?

I’m doing a landscape mesh test where I want it to only be lit dynamically (Cascaded shadow maps in the foreground and RayTraced distance field shadows in the background), so with that in mind I’ve created an empty scene with a directional light, sky light and landscape mesh. The directional light is set to movable, and the ‘static shadow’ option of the landscape mesh has been disabled, as well as ‘Use ambient Occlusion’ within the Lightmass settings. Why then when I build lighting does the scene still generate hundreds of lightmaps (256 component landscape).

I can’t seem to find any mention of this online. I’m assuming it has something to do with light data for the landscape, rather than actual shadow/lightmaps? Is there a way to completely disable lightmaps for a landscape (apart from having it live in its own level with force no precomputed lightmaps enabled).

Any help would be greatly appreciated.

Edit: Lowering the static lighting resolution and increasing the static lighting LOD reduces the lightmap count, but the question of why it’s still baking lightmaps at all remains.