DF Shadows artifacts

Hello all, I’m having some issues with ray traced DF shadows. When I try to put a spot light or point light with DF shadows enabled in the scene, but really close to another mesh, I get these artifacts:


I’m using dynamic lights. The light sources are not overlapping with the mesh. The artifacts seem to get a little better when I set the source radius of the light to something above zero, but more artifacts remain. So I’m forced to place the lights at least a foot away from anything to avoid those, but I’m screwed if I try to add wall lights or stuff like that.

I’ve tried to increase the distance field resolution on the meshes, but it does nothing.

Any ideas? Or should I just disable DF shadows? I’d really like to have them.

If it’s a wall light I would assume it does not move. If that is the case you should switch to static or stationary lights as that would save a lot of performance while simultaneously giving you higher quality shadows.

However, if there is a specific reason you need them to be dynamic you’ll have to work around these kind of effects. Shadow maps might not have these specific artifacts, but they have their own limitations.

Yeah, I kinda have a reason to use dynamic. Oh well, guess I’ll switch DF shadows off.