Destructable actor - weird behavior

I made a little test scene with a trigger and wall being a destructible actor. When I enter the trigger, damage is applied to the wall but no matter how high the damage and how low the damage threshold, it won’t fall apart.

exactly my problem:

I brought the wall into the shooter example and it breaks when I shoot it, it just doesn’t work with the BP damage input.

Hi Christian.Hecht,

I downloaded your project and found what the issue was but i was unable to come online yesterday. Anyway one of the problem was you were using vect(0,0,0) as the location instead of actor location. So change it like this:

Now select your Destructible Mesh in your viewport and on the details tab turn off Simulate Physics.

Now go ahead and destroy it. :slight_smile:

That fixed it, thanks a lot!

I want to apologize for using Vector 0,0,0 as the hurt origin in my original example. I only intended that as a basic example of using a vector, and it actually worked in my tests because of my positioning. This was something I edited recently in my post once I realized the confusion it could cause.

I am glad you have it resolved now. Thank you Satheesh for taking the time to look into this.

Glad i could help. :slight_smile:

Hi Christian,

I have found that a node to use for Destructible damage is Apply Radius Damage. Try using this basic setup.

I hope this helps.


Apply radius damage doesn’t work for me either. I also tried it with a different DM, still no luck.

Can you post the screenshot of your BP Setup?

It looks exactly like the one Stephen posted.


First, try enabling the “Full Damage” option. If that doesn’t help, then continue below.

Try the above setup in a new project, for instance in a First Person Blueprint Template. That Template also includes a Destructible Mesh in the Engine folder. You should not experience any issue adding an instance of the EditorCube_DM mesh to the level and using it in the level blueprint. Once you are successful here, import your own DM and see the results. By this method, you should be able to narrow down whether the issue lies with your DM or with something in your project.


Where can I find the “full damage” option? I already imported my DM into the shooter example project and I’m able to shoot/destroy it there.

Did you upgrade to the new Rocket? Full Damage option is available in Apply Radius Damage node in newer version i think. (Build #1904627)

I must be blind, ticked it. Still no luck.

Can you send me that project with apex mesh. I will definitely check it for you.

Ok, cool. Here’s the project:

I’m pretty sure it violates NDA to host rocket assets anywhere but on the Epic dropbox

You should probably remove that independently hosted project

and upload it here instead

I’m very excited about your project!

Keep us updated with pics!


@Nathan: True, I removed it.

@Satheesh: You can find the the project file zipped in the dropbox in my folder named “Christian_Hecht”

Did you catch this part of what Stephen wrote in his other post to Satheesh?

“In addition to this, there are also properties in the Details panels of the Destructible actor and for your projectile called “Use Async Scene” and “Check Async Scene on Move” respectively. Please make sure that your choice to either have this enabled or disabled is consistent between the two. Having one enabled and one disabled can cause the issue you see.”

You have to either have both selected, or both deselected.

please try both options and let us know :slight_smile:

Good luck!